summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb')
-rw-r--r--poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb26
1 files changed, 4 insertions, 22 deletions
diff --git a/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb b/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
index f7108013d3..b0d88de3aa 100644
--- a/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
+++ b/poky/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
@@ -17,14 +17,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
DEPENDS = "libgpg-error"
-RDEPENDS:${PN}-ptest = "bash make"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
- file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
+ file://no-native-gpg-error.patch \
file://run-ptest \
"
SRC_URI[sha256sum] = "ef14ae546b0084cd84259f61a55e07a38c3b53afc0f546bffcef2f01baffe9de"
@@ -39,8 +38,6 @@ inherit autotools texinfo binconfig-disabled pkgconfig ptest
EXTRA_OECONF = "--disable-asm"
EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
-PRIVATE_LIBS:${PN}-ptest:append = " libgcrypt.so.20"
-
PACKAGECONFIG ??= "capabilities"
PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
@@ -49,25 +46,10 @@ do_configure:prepend () {
rm -f ${S}/m4/gpg-error.m4
}
-# libgcrypt.pc is added locally and thus installed here
-do_install:append() {
- install -d ${D}/${libdir}/pkgconfig
- install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
-}
-
do_install_ptest() {
- cp -r --preserve=mode,links -v ${S} ${D}${PTEST_PATH}
- cp -r --preserve=mode,links -v ${B} ${D}${PTEST_PATH}
- rm ${D}${PTEST_PATH}/build/cipher/gost-s-box
- rm ${D}${PTEST_PATH}/build/doc/yat2m
- rm ${D}${PTEST_PATH}/build/libtool
- rm ${D}${PTEST_PATH}/build/config.status
- rm ${D}${PTEST_PATH}/build/config.log
- rm ${D}${PTEST_PATH}/build/src/mpicalc
- rm ${D}${PTEST_PATH}/${BP}/autom4te* -rf
- sed -i -e 's/Makefile:.*/Makefile-disabled:/' ${D}${PTEST_PATH}/build/Makefile
- find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "Makefile" \
- | xargs sed -e "s|${WORKDIR}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" -i
+ cd tests
+ oe_runmake testdrv-build testdrv
+ install testdrv $(srcdir=${S}/tests ./testdrv-build --files | sort | uniq) ${D}${PTEST_PATH}
}
FILES:${PN}-dev += "${bindir}/hmac256 ${bindir}/dumpsexp"