summaryrefslogtreecommitdiff
path: root/packages/a/util-linux
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-11 06:54:40 +0300
committerkx <kx@radix.pro>2023-04-11 06:54:40 +0300
commit19dc4c5d37a41a6fa8b1076b568191d0b61389c2 (patch)
tree858ac8f02295148d7fa50a031171badc550bad32 /packages/a/util-linux
parent616e36d9e9e3e56af1ea2db055012b77863d09e6 (diff)
downloadsources-19dc4c5d37a41a6fa8b1076b568191d0b61389c2.tar.xz
applications
Diffstat (limited to 'packages/a/util-linux')
-rw-r--r--packages/a/util-linux/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/a/util-linux/Makefile b/packages/a/util-linux/Makefile
new file mode 100644
index 0000000..82f03d7
--- /dev/null
+++ b/packages/a/util-linux/Makefile
@@ -0,0 +1,39 @@
+#
+# Project Home:
+# ============
+# https://kernel.org/pub/linux/utils/util-linux/
+#
+# Downloads:
+# =========
+# ftp://ftp.kernel.org/pub/linux/utils/util-linux/
+#
+
+url = https://kernel.org/pub/linux/utils/util-linux
+
+versions = 2.21.2 2.23 2.24 2.24.1 2.27 2.27.1 2.29.2 2.33.2 2.34 2.36 2.36.1 2.36.2 2.38.1
+
+pkgname = util-linux
+suffix = tar.xz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ version=`echo $$tarball | sed 's/\([a-zA-Z-]*\)\([0-9][.0-9][0-9]*\)\([\.].*\)/\2/'` ; \
+ wget -N $(url)/v$$version/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)