summaryrefslogtreecommitdiff
path: root/packages/b/Makefile
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-07 08:50:38 +0300
committerkx <kx@radix.pro>2023-04-07 08:50:38 +0300
commit56d70fdfbe2c742180a1a6a1976826a66bf8b96d (patch)
tree9fa99a644ff70c52c1c7d782b63270866043728f /packages/b/Makefile
parent982b3996a04e554ad3e300f86e413edfe1715b95 (diff)
downloadsources-56d70fdfbe2c742180a1a6a1976826a66bf8b96d.tar.xz
Database engines
Diffstat (limited to 'packages/b/Makefile')
-rw-r--r--packages/b/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/b/Makefile b/packages/b/Makefile
new file mode 100644
index 0000000..e86d94b
--- /dev/null
+++ b/packages/b/Makefile
@@ -0,0 +1,28 @@
+
+#
+# Following command helps to cheate SUBDIRS list:
+# $ tree -fid .
+#
+
+SUBDIRS := mariadb \
+ postgresql \
+ sqlite \
+ tdb \
+ tokyocabinet
+
+
+all-recursive downloads_clean-recursive:
+ @set fnord $(MAKEFLAGS); amf=$$2; \
+ target=`echo $@ | sed s/-recursive//`; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ local_target="$$target"; \
+ (cd $$subdir && $(MAKE) $$fnord $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; test -z "$$fail"
+
+all: all-recursive
+
+downloads_clean: downloads_clean-recursive
+
+.PHONY: all-recursive downloads_clean-recursive all downloads_clean