summaryrefslogtreecommitdiff
path: root/packages/d/perl-modules
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-05 22:22:22 +0300
committerkx <kx@radix.pro>2023-04-05 22:22:22 +0300
commit06fd19843ab5ddcb49c6f8741f1711778ff9f9eb (patch)
tree7820c561dfc028e65951d796014d58a241dd8c12 /packages/d/perl-modules
parenta0610b8d15a051d96037351979fca24039cfa884 (diff)
downloadsources-06fd19843ab5ddcb49c6f8741f1711778ff9f9eb.tar.xz
Perl modules
Diffstat (limited to 'packages/d/perl-modules')
-rw-r--r--packages/d/perl-modules/CPAN/B-C/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Clone/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/DBD-Pg/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/DBD-mysql/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/DBI/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Devel-CheckLib/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Error/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/IO-Socket-SSL/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/IO/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Locale-gettext/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/MailTools/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Makefile45
-rw-r--r--packages/d/perl-modules/CPAN/Module-Install/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Net-Domain/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/Time-Date/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/URI/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-LibXML/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-NamespaceSupport/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-Parser/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-SAX-Base/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-SAX-Expat/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-SAX/Makefile43
-rw-r--r--packages/d/perl-modules/CPAN/XML-Simple/Makefile43
-rw-r--r--packages/d/perl-modules/Makefile25
-rw-r--r--packages/d/perl-modules/perl-SGMLS/Makefile45
25 files changed, 1061 insertions, 0 deletions
diff --git a/packages/d/perl-modules/CPAN/B-C/Makefile b/packages/d/perl-modules/CPAN/B-C/Makefile
new file mode 100644
index 0000000..20bab28
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/B-C/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/B-C
+
+versions = 1.57
+pkgname = B-C
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Clone/Makefile b/packages/d/perl-modules/CPAN/Clone/Makefile
new file mode 100644
index 0000000..39712cf
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Clone/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Clone
+
+versions = 0.46
+pkgname = Clone
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/DBD-Pg/Makefile b/packages/d/perl-modules/CPAN/DBD-Pg/Makefile
new file mode 100644
index 0000000..5c68ae5
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/DBD-Pg/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/DBD-Pg
+
+versions = 3.16.0 3.16.3
+pkgname = DBD-Pg
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/DBD-mysql/Makefile b/packages/d/perl-modules/CPAN/DBD-mysql/Makefile
new file mode 100644
index 0000000..8139e53
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/DBD-mysql/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/DBD-mysql
+
+versions = 4.050
+pkgname = DBD-mysql
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/DBI/Makefile b/packages/d/perl-modules/CPAN/DBI/Makefile
new file mode 100644
index 0000000..4d10bbf
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/DBI/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/DBI
+
+versions = 1.643
+pkgname = DBI
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Devel-CheckLib/Makefile b/packages/d/perl-modules/CPAN/Devel-CheckLib/Makefile
new file mode 100644
index 0000000..821f651
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Devel-CheckLib/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Devel-CheckLib
+
+versions = 1.16
+pkgname = Devel-CheckLib
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Error/Makefile b/packages/d/perl-modules/CPAN/Error/Makefile
new file mode 100644
index 0000000..cedfd9d
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Error/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Error
+
+versions = 0.17029
+pkgname = Error
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/IO-Socket-SSL/Makefile b/packages/d/perl-modules/CPAN/IO-Socket-SSL/Makefile
new file mode 100644
index 0000000..4942a25
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/IO-Socket-SSL/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/IO-Socket-SSL
+
+versions = 2.075
+pkgname = IO-Socket-SSL
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/IO/Makefile b/packages/d/perl-modules/CPAN/IO/Makefile
new file mode 100644
index 0000000..f68e1e0
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/IO/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/IO
+
+versions = 1.50
+pkgname = IO
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Locale-gettext/Makefile b/packages/d/perl-modules/CPAN/Locale-gettext/Makefile
new file mode 100644
index 0000000..ff72085
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Locale-gettext/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Locale-gettext
+
+versions = 1.07
+pkgname = gettext
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/MailTools/Makefile b/packages/d/perl-modules/CPAN/MailTools/Makefile
new file mode 100644
index 0000000..0086b8c
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/MailTools/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/MailTools
+
+versions = 2.21
+pkgname = MailTools
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Makefile b/packages/d/perl-modules/CPAN/Makefile
new file mode 100644
index 0000000..4881705
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Makefile
@@ -0,0 +1,45 @@
+
+#
+# Following command helps to cheate SUBDIRS list:
+# $ tree -fid .
+#
+
+SUBDIRS := B-C \
+ Clone \
+ DBD-Pg \
+ DBD-mysql \
+ DBI \
+ Devel-CheckLib \
+ Error \
+ IO \
+ IO-Socket-SSL \
+ Locale-gettext \
+ MailTools \
+ Module-Install \
+ Net-Domain \
+ Time-Date \
+ URI \
+ XML-LibXML \
+ XML-NamespaceSupport \
+ XML-Parser \
+ XML-SAX \
+ XML-SAX-Base \
+ XML-SAX-Expat \
+ XML-Simple
+
+
+all-recursive downloads_clean-recursive:
+ @set fnord $(MAKEFLAGS); amf=$$2; \
+ target=`echo $@ | sed s/-recursive//`; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ local_target="$$target"; \
+ (cd $$subdir && $(MAKE) $$fnord $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; test -z "$$fail"
+
+all: all-recursive
+
+downloads_clean: downloads_clean-recursive
+
+.PHONY: all-recursive downloads_clean-recursive all downloads_clean
diff --git a/packages/d/perl-modules/CPAN/Module-Install/Makefile b/packages/d/perl-modules/CPAN/Module-Install/Makefile
new file mode 100644
index 0000000..3440eea
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Module-Install/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Module-Install
+
+versions = 1.19
+pkgname = Module-Install
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Net-Domain/Makefile b/packages/d/perl-modules/CPAN/Net-Domain/Makefile
new file mode 100644
index 0000000..124de09
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Net-Domain/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Net-Domain
+
+versions = 3.14 3.15
+pkgname = libnet
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/Time-Date/Makefile b/packages/d/perl-modules/CPAN/Time-Date/Makefile
new file mode 100644
index 0000000..0e129b8
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/Time-Date/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/Time-Date
+
+versions = 0.05
+pkgname = Time-Date
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/URI/Makefile b/packages/d/perl-modules/CPAN/URI/Makefile
new file mode 100644
index 0000000..2dc3cbe
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/URI/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/URI
+
+versions = 5.16 5.17
+pkgname = URI
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-LibXML/Makefile b/packages/d/perl-modules/CPAN/XML-LibXML/Makefile
new file mode 100644
index 0000000..b5af910
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-LibXML/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-LibXML
+
+versions = 2.0208
+pkgname = XML-LibXML
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-NamespaceSupport/Makefile b/packages/d/perl-modules/CPAN/XML-NamespaceSupport/Makefile
new file mode 100644
index 0000000..8f316be
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-NamespaceSupport/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-NamespaceSupport
+
+versions = 1.12
+pkgname = XML-NamespaceSupport
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-Parser/Makefile b/packages/d/perl-modules/CPAN/XML-Parser/Makefile
new file mode 100644
index 0000000..21dd66c
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-Parser/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-Parser
+
+versions = 2.46
+pkgname = XML-Parser
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-SAX-Base/Makefile b/packages/d/perl-modules/CPAN/XML-SAX-Base/Makefile
new file mode 100644
index 0000000..1e1c170
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-SAX-Base/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-SAX-Base
+
+versions = 1.09
+pkgname = XML-SAX-Base
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-SAX-Expat/Makefile b/packages/d/perl-modules/CPAN/XML-SAX-Expat/Makefile
new file mode 100644
index 0000000..5227a2c
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-SAX-Expat/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-SAX-Expat
+
+versions = 0.51
+pkgname = XML-SAX-Expat
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-SAX/Makefile b/packages/d/perl-modules/CPAN/XML-SAX/Makefile
new file mode 100644
index 0000000..a94bc5a
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-SAX/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-SAX
+
+versions = 1.02
+pkgname = XML-SAX
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/CPAN/XML-Simple/Makefile b/packages/d/perl-modules/CPAN/XML-Simple/Makefile
new file mode 100644
index 0000000..08689bd
--- /dev/null
+++ b/packages/d/perl-modules/CPAN/XML-Simple/Makefile
@@ -0,0 +1,43 @@
+#
+# Project Home:
+# ============
+# http://www.cpan.org/modules/index.html
+#
+# Install instruction:
+# ===================
+# http://www.cpan.org/modules/INSTALL.html
+#
+# Search CPAN:
+# ===========
+# https://metacpan.org
+# http://search.cpan.org
+#
+
+url = https://ftp.radix.pro/3pp/perl-modules/CPAN/XML-Simple
+
+versions = 2.25
+pkgname = XML-Simple
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
diff --git a/packages/d/perl-modules/Makefile b/packages/d/perl-modules/Makefile
new file mode 100644
index 0000000..4913864
--- /dev/null
+++ b/packages/d/perl-modules/Makefile
@@ -0,0 +1,25 @@
+
+#
+# Following command helps to cheate SUBDIRS list:
+# $ tree -fid .
+#
+
+SUBDIRS := CPAN \
+ perl-SGMLS
+
+
+all-recursive downloads_clean-recursive:
+ @set fnord $(MAKEFLAGS); amf=$$2; \
+ target=`echo $@ | sed s/-recursive//`; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ local_target="$$target"; \
+ (cd $$subdir && $(MAKE) $$fnord $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; test -z "$$fail"
+
+all: all-recursive
+
+downloads_clean: downloads_clean-recursive
+
+.PHONY: all-recursive downloads_clean-recursive all downloads_clean
diff --git a/packages/d/perl-modules/perl-SGMLS/Makefile b/packages/d/perl-modules/perl-SGMLS/Makefile
new file mode 100644
index 0000000..682b933
--- /dev/null
+++ b/packages/d/perl-modules/perl-SGMLS/Makefile
@@ -0,0 +1,45 @@
+#
+# Project Home:
+# ============
+# https://www.garshol.priv.no/download/xmltools/prod/SGMLSpm.html
+# https://metacpan.org/release/RAAB/SGMLSpm-1.1
+#
+# Downloads:
+# =========
+# https://cpan.metacpan.org/authors/id/R/RA/RAAB/SGMLSpm-1.1.tar.gz
+#
+
+url = https://cpan.metacpan.org/authors/id/R/RA/RAAB
+
+versions = 1.1
+
+src_name = SGMLSpm
+pkg_name = perl-SGMLS
+suffix = tar.xz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkg_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for version in $(versions) ; do \
+ wget -N $(url)/$(src_name)-$$version.tar.gz ; \
+ tar xzvf $(src_name)-$$version.tar.gz ; \
+ mv $(src_name)-$$version $(pkg_name)-$$version ; \
+ tar cJvf $(pkg_name)-$$version.$(suffix) $(pkg_name)-$$version ; \
+ rm -rf $(pkg_name)-$$version $(src_name)-$$version.tar.gz ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)