summaryrefslogtreecommitdiff
path: root/packages/d/pkg-config
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-07 10:30:20 +0300
committerkx <kx@radix.pro>2023-04-07 10:30:20 +0300
commit293cb571e521af88e2d5fb77490653c054d2a3b7 (patch)
tree8089f0eb61ad0b350a8f4e321243cff2d489594b /packages/d/pkg-config
parent4dd2d7b3f9a5a05236ac3b08a1d98f0ce6fb3c18 (diff)
downloadsources-293cb571e521af88e2d5fb77490653c054d2a3b7.tar.xz
pkg-config-0.29.2
Diffstat (limited to 'packages/d/pkg-config')
-rw-r--r--packages/d/pkg-config/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/d/pkg-config/Makefile b/packages/d/pkg-config/Makefile
new file mode 100644
index 0000000..168d5c7
--- /dev/null
+++ b/packages/d/pkg-config/Makefile
@@ -0,0 +1,39 @@
+#
+# Project Home:
+# ============
+# https://pkgconfig.freedesktop.org
+#
+# Downloads:
+# =========
+# https://pkgconfig.freedesktop.org/releases
+#
+
+url = https://pkgconfig.freedesktop.org/releases
+
+versions = 0.25 0.26 0.27 0.28 0.29 0.29.2
+
+pkg_name = pkg-config
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkg_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)