summaryrefslogtreecommitdiff
path: root/packages/d
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-06 10:43:27 +0300
committerkx <kx@radix.pro>2023-04-06 10:43:27 +0300
commit2992f3e010fa299003630239a496a7ab3349025a (patch)
tree492578ee2a57e5b507fb121f36eaaf776ceada8d /packages/d
parentf7e1268e0895b2d6ec7467de603a5ef8a45cf556 (diff)
downloadsources-2992f3e010fa299003630239a496a7ab3349025a.tar.xz
service Makefiles
Diffstat (limited to 'packages/d')
-rw-r--r--packages/d/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/d/Makefile b/packages/d/Makefile
new file mode 100644
index 0000000..14e4c36
--- /dev/null
+++ b/packages/d/Makefile
@@ -0,0 +1,24 @@
+
+#
+# Following command helps to cheate SUBDIRS list:
+# $ tree -fid .
+#
+
+SUBDIRS := perl-modules
+
+
+all-recursive downloads_clean-recursive:
+ @set fnord $(MAKEFLAGS); amf=$$2; \
+ target=`echo $@ | sed s/-recursive//`; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ local_target="$$target"; \
+ (cd $$subdir && $(MAKE) $$fnord $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; test -z "$$fail"
+
+all: all-recursive
+
+downloads_clean: downloads_clean-recursive
+
+.PHONY: all-recursive downloads_clean-recursive all downloads_clean