summaryrefslogtreecommitdiff
path: root/packages/l/hyphen/Makefile
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-05-25 14:07:01 +0300
committerkx <kx@radix.pro>2023-05-25 14:07:01 +0300
commite0d5c2c4092e4cb8cb5a7435d2bd483be5897c2b (patch)
tree28082e1a3db94e37c99549e114f560dde0dd205a /packages/l/hyphen/Makefile
parentd26f020ca0d2c95f5b78035eaeaa1cca1fc58d7c (diff)
downloadsources-e0d5c2c4092e4cb8cb5a7435d2bd483be5897c2b.tar.xz
hyphen; libmanette
Diffstat (limited to 'packages/l/hyphen/Makefile')
-rw-r--r--packages/l/hyphen/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/l/hyphen/Makefile b/packages/l/hyphen/Makefile
new file mode 100644
index 0000000..aaeddad
--- /dev/null
+++ b/packages/l/hyphen/Makefile
@@ -0,0 +1,40 @@
+#
+# Project Home:
+# ============
+# https://sourceforge.net/projects/hunspell
+#
+# Downloads:
+# =========
+# https://sourceforge.net/projects/hunspell/files/Hyphen/2.8/hyphen-${VERSION}.tar.gz
+#
+
+url = https://downloads.sourceforge.net/project/hunspell/Hyphen
+
+versions = 2.8.8
+
+pkgname = hyphen
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ version=`echo $$tarball | sed 's/\([a-zA-Z-]*\)\([0-9][.][0-9]\)\(\..*\)/\2/'` ; \
+ wget -N $(url)/$$version/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)