summaryrefslogtreecommitdiff
path: root/packages/l/termcap-compat
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-09 03:24:10 +0300
committerkx <kx@radix.pro>2023-04-09 03:24:10 +0300
commit3dd1914515dc5c714451bc4148f0abb51672ed06 (patch)
tree59f905d8f79957d77649bb81f6f4db4615fe1f46 /packages/l/termcap-compat
parentc0eee091446a07e56576b7d855dd09f0da9968c8 (diff)
downloadsources-3dd1914515dc5c714451bc4148f0abb51672ed06.tar.xz
libraries
Diffstat (limited to 'packages/l/termcap-compat')
-rw-r--r--packages/l/termcap-compat/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/l/termcap-compat/Makefile b/packages/l/termcap-compat/Makefile
new file mode 100644
index 0000000..9ec99fa
--- /dev/null
+++ b/packages/l/termcap-compat/Makefile
@@ -0,0 +1,43 @@
+#
+# Downloads:
+# =========
+# http://archive.debian.org/debian-archive/debian/pool/main/t/termcap-compat/
+# http://ftp.de.debian.org/debian-archive/debian/pool/main/t/termcap-compat/
+# ftp://ftp.de.debian.org/debian-archive/debian/pool/main/t/termcap-compat/
+
+url = ftp://ftp.de.debian.org/debian-archive/debian/pool/main/t/termcap-compat
+
+versions = 1.2.3
+
+pkgname = termcap-compat
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)_, $(versions)))
+descriptions = $(addsuffix .dsc, $(addprefix $(pkgname)_, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(descriptions) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(descriptions):
+ @echo -e "\n======= Downloading source descriptions =======\n"
+ @for description in $(descriptions) ; do \
+ wget -N $(url)/$$description ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(descriptions) $(sha1s)