summaryrefslogtreecommitdiff
path: root/packages/n/whois
diff options
context:
space:
mode:
authorkx <kx@radix.pro>2023-04-09 23:18:24 +0300
committerkx <kx@radix.pro>2023-04-09 23:18:24 +0300
commit8b7e76c7ad2445c0920e9d056728f7b6baaa0c43 (patch)
treeda231ea7d17ddaa541cfdd758945c614c385575f /packages/n/whois
parent3dd1914515dc5c714451bc4148f0abb51672ed06 (diff)
downloadsources-8b7e76c7ad2445c0920e9d056728f7b6baaa0c43.tar.xz
network packages
Diffstat (limited to 'packages/n/whois')
-rw-r--r--packages/n/whois/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/packages/n/whois/Makefile b/packages/n/whois/Makefile
new file mode 100644
index 0000000..b3e08e4
--- /dev/null
+++ b/packages/n/whois/Makefile
@@ -0,0 +1,69 @@
+#
+# Project Home:
+# ============
+# https://github.com/rfc1036/whois
+#
+# GitHub:
+# ======
+# https://github.com/rfc1036/whois
+# clone git://github.com/rfc1036/whois.git
+#
+# Old Download Link:
+# =================
+# ftp://ftp.debian.org/debian/pool/main/w/whois/whois_5.2.1.tar.xz
+#
+
+url = https://github.com/rfc1036/whois.git
+
+repo_name = whois
+
+versions = 5.0.25 5.2.1 5.2.11 5.2.12 5.5.2 5.5.8 5.5.9 5.5.16
+
+pkgname = whois
+suffix = tar.xz
+
+git_repo = .git_clone
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+TARGETS = repository_clean
+
+
+all: $(TARGETS)
+
+.PHONY: downloads_clean repository_clean
+
+$(git_repo):
+ @echo -e "\n======= Clone $(repo_name).git repository =======\n"
+ @rm -rf $(repo_name)
+ @if [ "$(url)" = 'git://radix.pro' ]; then \
+ git clone $(url)/$(repo_name).git $(repo_name) ; \
+ else \
+ git clone $(url) $(repo_name) ; \
+ fi
+ @touch $@
+
+$(tarballs): $(git_repo)
+ @for version in $(versions) ; do \
+ tag=`echo v$$version` ; \
+ if [ ! -f $(repo_name)-$$version.$(suffix) ]; then \
+ echo -e "\n======= Creating '$(repo_name)-$$version.$(suffix)' snapshot =======" ; \
+ ( cd $(repo_name) && \
+ git archive --format=tar --prefix=$(repo_name)-$$version/ $$tag | \
+ xz >../$(repo_name)-$$version.$(suffix) ) ; \
+ fi ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+repository_clean: $(sha1s)
+ @echo -e "\n======= Remove cloned $(repo_name).git repository =======\n"
+ @rm -rf $(git_repo) $(repo_name)
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
+ @rm -rf $(git_repo) $(repo_name)