summaryrefslogtreecommitdiff
path: root/packages/a/man2html
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/man2html')
-rw-r--r--packages/a/man2html/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/a/man2html/Makefile b/packages/a/man2html/Makefile
new file mode 100644
index 0000000..a460708
--- /dev/null
+++ b/packages/a/man2html/Makefile
@@ -0,0 +1,49 @@
+#
+# Project Home:
+# ============
+# https://ftp.invisible-island.net/scripts/#others_scripts
+# https://ftp.invisible-island.net/scripts/man2html.html
+#
+# Downloads:
+# =========
+# ftp://ftp.invisible-island.net/scripts
+# https://invisible-mirror.net/archives/scripts
+#
+
+url = https://invisible-mirror.net/archives/scripts
+
+versions = 20200125 20221106
+
+pkgname = man2html
+suffix = tar.xz
+
+src_tarball = other-scripts
+src_suffix = tgz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for version in $(versions) ; do \
+ wget -N $(url)/$(src_tarball)-$$version.$(src_suffix) ; \
+ mkdir -p $(pkgname)-$$version ; \
+ tar -C $(pkgname)-$$version/ --strip-components=1 \
+ -xzf $(src_tarball)-$$version.$(src_suffix) $(src_tarball)-$$version/$(pkgname) ; \
+ tar -cJf $(pkgname)-$$version.$(suffix) $(pkgname)-$$version ; \
+ rm -rf $(pkgname)-$$version $(src_tarball)-$$version.$(src_suffix) ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)