summaryrefslogtreecommitdiff
path: root/packages/a/pciutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/pciutils/Makefile')
-rw-r--r--packages/a/pciutils/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/a/pciutils/Makefile b/packages/a/pciutils/Makefile
new file mode 100644
index 0000000..613b32d
--- /dev/null
+++ b/packages/a/pciutils/Makefile
@@ -0,0 +1,42 @@
+#
+# Project Home:
+# ============
+# https://www.kernel.org
+#
+# Downloads:
+# =========
+# ftp://metalab.unc.edu/pub/Linux/hardware
+# ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+# ftp://ftp.kernel.org/pub/software/utils/pciutils
+# https://www.kernel.org/pub/software/utils/pciutils
+#
+
+url = https://www.kernel.org/pub/software/utils/pciutils
+
+versions = 3.2.0 3.2.1 3.3.1 3.4.1 3.6.2 3.7.0 3.8.0 3.9.0
+
+pkgname = pciutils
+suffix = tar.xz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)