summaryrefslogtreecommitdiff
path: root/packages/a/tcsh
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/tcsh')
-rw-r--r--packages/a/tcsh/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/a/tcsh/Makefile b/packages/a/tcsh/Makefile
new file mode 100644
index 0000000..2e92ab9
--- /dev/null
+++ b/packages/a/tcsh/Makefile
@@ -0,0 +1,39 @@
+#
+# Project Home:
+# ============
+# https://www.tcsh.org
+#
+# Downloads:
+# =========
+# https://astron.com/pub/tcsh
+# ftp://ftp.astron.com/pub/tcsh [US]
+#
+
+url = https://astron.com/pub/tcsh
+
+versions = 6.24.00 6.24.08
+pkg_name = tcsh
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkg_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for version in $(versions) ; do \
+ wget -N $(url)/$(pkg_name)-$$version.$(suffix) ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)