summaryrefslogtreecommitdiff
path: root/packages/a/utempter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/a/utempter/Makefile')
-rw-r--r--packages/a/utempter/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/a/utempter/Makefile b/packages/a/utempter/Makefile
new file mode 100644
index 0000000..b737a5c
--- /dev/null
+++ b/packages/a/utempter/Makefile
@@ -0,0 +1,51 @@
+#
+# Project Home:
+# ============
+# https://www.openhub.net/p/libutempter
+#
+# Git:
+# ===
+# git: git://git.altlinux.org/people/ldv/packages/libutempter.git
+#
+# GitWeb:
+# ======
+# gitweb: https://git.altlinux.org/people/ldv/packages/?p=libutempter.git
+#
+# GitHub:
+# ======
+# https://github.com/altlinux/libutempter
+#
+# Downloads:
+# =========
+# ftp://ftp.altlinux.org/pub/people/ldv/utempter
+#
+
+url = ftp://ftp.altlinux.org/pub/people/ldv/utempter
+
+versions = 1.2.1
+
+pkg_name = libutempter
+suffix = tar.gz
+
+tarballs = $(addsuffix .$(suffix), $(addprefix $(pkg_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+
+all: $(tarballs) $(sha1s)
+
+.PHONY: downloads_clean
+
+$(tarballs):
+ @echo -e "\n======= Downloading source tarballs =======\n"
+ @for tarball in $(tarballs) ; do \
+ wget -N $(url)/$$tarball ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======\n" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)