summaryrefslogtreecommitdiff
path: root/packages/d/python-modules/wheel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/d/python-modules/wheel/Makefile')
-rw-r--r--packages/d/python-modules/wheel/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/packages/d/python-modules/wheel/Makefile b/packages/d/python-modules/wheel/Makefile
new file mode 100644
index 0000000..8eec29a
--- /dev/null
+++ b/packages/d/python-modules/wheel/Makefile
@@ -0,0 +1,66 @@
+#
+# Project Home:
+# ============
+# https://pypi.python.org/pypi/wheel
+# https://bitbucket.org/pypa/wheel
+#
+# BitBucket.org:
+# =============
+# hg clone https://bitbucket.org/pypa/wheel
+#
+# GitGub:
+# =========
+# https://github.com/pypa/wheel.git
+#
+
+url = https://github.com/pypa
+
+repo_name = wheel
+
+versions = 0.29.0 0.30.0 0.33.6 0.34.2 0.36.2 0.37.0 0.37.1
+
+suffix = tar.xz
+
+TAGS = $(versions)
+
+git_repo = .git_clone
+tarballs = $(addsuffix .$(suffix), $(addprefix $(repo_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+TARGETS = repository_clean
+
+all: $(TARGETS)
+
+.PHONY: downloads_clean repository_clean
+
+$(git_repo):
+ @echo -e "\n======= Clone $(repo_name).git repository =======\n"
+ @rm -rf $(repo_name)
+ @git clone $(url)/$(repo_name).git $(repo_name)
+ @touch $@
+
+
+$(tarballs): $(git_repo)
+ @for version in $(TAGS) ; do \
+ tag=`echo $$version`; \
+ if [ ! -f $(repo_name)-$$version.$(suffix) ]; then \
+ echo -e "\n======= Creating '$(repo_name)-$$version.$(suffix)' snapshot =======" ; \
+ ( cd $(repo_name) && \
+ git archive --format=tar --prefix=$(repo_name)-$$version/ $$tag | \
+ xz >../$(repo_name)-$$version.$(suffix) ) ; \
+ fi ; \
+ done
+
+$(sha1s): %.$(suffix).sha1sum : %.$(suffix)
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+repository_clean: $(sha1s)
+ @echo -e "\n======= Remove cloned $(repo_name).git repository =======\n"
+ @rm -rf $(git_repo) $(repo_name)
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
+ @rm -rf $(git_repo) $(repo_name)