summaryrefslogtreecommitdiff
path: root/packages/x/appstream-glib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/x/appstream-glib/Makefile')
-rw-r--r--packages/x/appstream-glib/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/packages/x/appstream-glib/Makefile b/packages/x/appstream-glib/Makefile
new file mode 100644
index 0000000..08f0ba5
--- /dev/null
+++ b/packages/x/appstream-glib/Makefile
@@ -0,0 +1,62 @@
+#
+# Project Home:
+# ============
+# https://github.com/hughsie/appstream-glib
+#
+# Clone:
+# =====
+# git clone https://github.com/hughsie/appstream-glib.git
+#
+
+url = https://github.com/hughsie
+
+repo_name = appstream-glib
+pkg_name = appstream-glib
+suffix = tar.xz
+
+versions = 0.8.2
+
+# List of tags to be extracted:
+TAGS = $(addprefix v, $(versions))
+
+git_repo = .git_clone
+tarballs = $(addsuffix .tar.xz, $(addprefix $(pkg_name)-, $(versions)))
+sha1s = $(addsuffix .sha1sum, $(tarballs))
+
+TARGETS = repository_clean
+
+
+all: $(TARGETS)
+
+.PHONY: downloads_clean repository_clean
+
+$(git_repo):
+ @echo -e "\n======= Clone $(repo_name).git repository =======\n"
+ @rm -rf $(repo_name)
+ @git clone $(url)/$(repo_name).git $(repo_name)
+ @touch $@
+
+$(tarballs): $(git_repo)
+ @for version in $(versions) ; do \
+ tag=appstream_glib_`echo $$version | sed 's,\.,_,g'` ; \
+ if [ ! -f $(repo_name)-$$version.$(suffix) ]; then \
+ echo -e "\n======= Creating '$(repo_name)-$$version.$(suffix)' snapshot =======" ; \
+ ( cd $(repo_name) && \
+ git archive --format=tar --prefix=$(pkg_name)-$$version/ $$tag | \
+ xz >../$(pkg_name)-$$version.$(suffix) ) ; \
+ fi ; \
+ done
+
+$(sha1s): %.tar.xz.sha1sum : %.tar.xz
+ @for tarball in $< ; do \
+ echo -e "\n======= Calculation the '$$tarball' sha1sum =======" ; \
+ sha1sum --binary $$tarball > $$tarball.sha1sum ; \
+ done
+
+repository_clean: $(sha1s)
+ @echo -e "\n======= Remove cloned $(repo_name).git repository =======\n"
+ @rm -rf $(git_repo) $(repo_name)
+
+downloads_clean:
+ @rm -rf $(tarballs) $(sha1s)
+ @rm -rf $(git_repo) $(repo_name)