summaryrefslogtreecommitdiff
path: root/packages/x/ayatana/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/x/ayatana/Makefile')
-rw-r--r--packages/x/ayatana/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/x/ayatana/Makefile b/packages/x/ayatana/Makefile
new file mode 100644
index 0000000..f7d051c
--- /dev/null
+++ b/packages/x/ayatana/Makefile
@@ -0,0 +1,26 @@
+
+#
+# Following command helps to cheate SUBDIRS list:
+# $ tree -fid .
+#
+
+SUBDIRS := ido \
+ indicator \
+ appindicator
+
+
+all-recursive downloads_clean-recursive:
+ @set fnord $(MAKEFLAGS); amf=$$2; \
+ target=`echo $@ | sed s/-recursive//`; \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ local_target="$$target"; \
+ (cd $$subdir && $(MAKE) $$fnord $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; test -z "$$fail"
+
+all: all-recursive
+
+downloads_clean: downloads_clean-recursive
+
+.PHONY: all-recursive downloads_clean-recursive all downloads_clean