summaryrefslogtreecommitdiff
path: root/scripts/package/mkdebian
diff options
context:
space:
mode:
authorMasahiro Yamada <masahiroy@kernel.org>2023-03-12 23:07:27 +0300
committerMasahiro Yamada <masahiroy@kernel.org>2023-03-15 09:15:07 +0300
commit7a531c21f83d7c62825d00bee3a76c1ccfb5de9f (patch)
treec96a175a48f4cc212b43d4a3ce72b30e3bfd9990 /scripts/package/mkdebian
parent2fd6c4553c962ec7ea8a60c0a3632c7e984800f0 (diff)
downloadlinux-7a531c21f83d7c62825d00bee3a76c1ccfb5de9f.tar.xz
kbuild: deb-pkg: do not take KERNELRELEASE from the source version
KERNELRELEASE does not need to match the package version in changelog. Rather, it conventially matches what is called 'ABINAME', which is a part of the binary package names. Both are the same by default, but the former might be overridden by KDEB_PKGVERSION. In this case, the resulting package would not boot because /lib/modules/$(uname -r) does not point the module directory. Partially revert 3ab18a625ce4 ("kbuild: deb-pkg: improve the usability of source package"). Reported-by: Péter Ujfalusi <peter.ujfalusi@linux.intel.com> Fixes: 3ab18a625ce4 ("kbuild: deb-pkg: improve the usability of source package") Signed-off-by: Masahiro Yamada <masahiroy@kernel.org> Tested-by: Peter Ujfalusi <peter.ujfalusi@linux.intel.com>
Diffstat (limited to 'scripts/package/mkdebian')
-rwxr-xr-xscripts/package/mkdebian1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/package/mkdebian b/scripts/package/mkdebian
index c6fbfb9f74ba..31b050368cd0 100755
--- a/scripts/package/mkdebian
+++ b/scripts/package/mkdebian
@@ -244,6 +244,7 @@ KERNELRELEASE = ${KERNELRELEASE}
build-indep:
build-arch:
\$(MAKE) -f \$(srctree)/Makefile ARCH=${ARCH} \
+ KERNELRELEASE=\$(KERNELRELEASE) \
\$(shell \$(srctree)/scripts/package/deb-build-option) \
olddefconfig all