summaryrefslogtreecommitdiff
path: root/scripts/package/mkdebian
diff options
context:
space:
mode:
authorMasahiro Yamada <masahiroy@kernel.org>2023-08-01 15:19:26 +0300
committerMasahiro Yamada <masahiroy@kernel.org>2023-08-07 19:08:54 +0300
commitd9287ea8ffc9be2ab4c81c32e1ca54478425ba38 (patch)
tree8f5070cc4659590ae96b133593ca1fd3df5820c5 /scripts/package/mkdebian
parent4b970e436523ed34da4ced74ad2b81e5a4f573f2 (diff)
downloadlinux-d9287ea8ffc9be2ab4c81c32e1ca54478425ba38.tar.xz
kbuild: deb-pkg: split debian/rules
debian/rules is generated by shell, but the escape sequence (\$) is unreadable. debian/rules embeds only two variables (ARCH and KERNELRELEASE). Split them out to debian/rules.vars, and check-in the rest of Makefile code to scripts/package/debian/rules. Signed-off-by: Masahiro Yamada <masahiroy@kernel.org> Tested-by: Nathan Chancellor <nathan@kernel.org> Reviewed-by: Nicolas Schier <nicolas@fjasle.eu>
Diffstat (limited to 'scripts/package/mkdebian')
-rwxr-xr-xscripts/package/mkdebian34
1 files changed, 5 insertions, 29 deletions
diff --git a/scripts/package/mkdebian b/scripts/package/mkdebian
index 2829f5b8aea6..5044224cf671 100755
--- a/scripts/package/mkdebian
+++ b/scripts/package/mkdebian
@@ -263,35 +263,11 @@ Description: Linux kernel debugging symbols for $version
EOF
fi
-cat <<EOF > debian/rules
-#!/usr/bin/make -f
-
-srctree ?= .
-KERNELRELEASE = ${KERNELRELEASE}
-
-.PHONY: clean build build-arch build-indep binary binary-arch binary-indep
-
-build-indep:
-build-arch:
- \$(MAKE) -f \$(srctree)/Makefile ARCH=${ARCH} \
- KERNELRELEASE=\$(KERNELRELEASE) \
- \$(shell \$(srctree)/scripts/package/deb-build-option) \
- olddefconfig all
-
-build: build-arch
-
-binary-indep:
-binary-arch: build-arch
- \$(MAKE) -f \$(srctree)/Makefile ARCH=${ARCH} \
- KERNELRELEASE=\$(KERNELRELEASE) \
- run-command KBUILD_RUN_COMMAND=+\$(srctree)/scripts/package/builddeb
-
-clean:
- rm -rf debian/files debian/linux-*
- \$(MAKE) -f \$(srctree)/Makefile ARCH=${ARCH} clean
-
-binary: binary-arch
+cat <<EOF > debian/rules.vars
+ARCH := ${ARCH}
+KERNELRELEASE := ${KERNELRELEASE}
EOF
-chmod +x debian/rules
+
+cp "${srctree}/scripts/package/debian/rules" debian/
exit 0