summaryrefslogtreecommitdiff
path: root/tools/buildman/pyproject.toml
diff options
context:
space:
mode:
authorSimon Glass <sjg@chromium.org>2023-02-24 04:18:13 +0300
committerSimon Glass <sjg@chromium.org>2023-03-08 22:40:49 +0300
commit0de2ffe717766c16f66775abf95d623f15489e83 (patch)
tree0e95a8a29aa6ea9eb3e4dc1f2e522f6bee9d7cae /tools/buildman/pyproject.toml
parentd85f7909f8fed1e06fe56e03c52d5ff6d8dfbdcf (diff)
downloadu-boot-0de2ffe717766c16f66775abf95d623f15489e83.tar.xz
buildman: Add support for building a buildman PyPi package
Create the necessary files to build this new package. It is not actually clear whether this is useful, since buildman has no purpose outside U-Boot. It is included for completeness, since adding this later would be more trouble. Move the main program into a function so that it can easily be called by the PyPi-created script. Signed-off-by: Simon Glass <sjg@chromium.org>
Diffstat (limited to 'tools/buildman/pyproject.toml')
-rw-r--r--tools/buildman/pyproject.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/tools/buildman/pyproject.toml b/tools/buildman/pyproject.toml
new file mode 100644
index 0000000000..4d75e772ee
--- /dev/null
+++ b/tools/buildman/pyproject.toml
@@ -0,0 +1,29 @@
+[build-system]
+requires = ["setuptools>=61.0"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "buildman"
+version = "0.0.2"
+authors = [
+ { name="Simon Glass", email="sjg@chromium.org" },
+]
+dependencies = ["u_boot_pylib", "patch-manager"]
+description = "Buildman build tool for U-Boot"
+readme = "README.rst"
+requires-python = ">=3.7"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
+ "Operating System :: OS Independent",
+]
+
+[project.urls]
+"Homepage" = "https://u-boot.readthedocs.io/en/latest/build/buildman.html"
+"Bug Tracker" = "https://source.denx.de/groups/u-boot/-/issues"
+
+[project.scripts]
+buildman = "buildman.main:run_buildman"
+
+[tool.setuptools.package-data]
+buildman = ["*.rst"]