summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2024-04-17 23:43:14 +0300
committerEd Tanous <ed@tanous.net>2024-04-18 18:56:58 +0300
commit211cfa49d10cb251b6504bacb13d8e87b4d9c1e4 (patch)
tree7663c8a4b476917081460ad27f4ffe95a08b275c /meson.build
parent56d0bb068b69c5b8853e44d7af179030adcacd64 (diff)
downloadbmcweb-211cfa49d10cb251b6504bacb13d8e87b4d9c1e4.tar.xz
Update nghttp2 1.60->1.61
They seem to have gotten rid of the nghttp2_static target, so go back to relying on the "normal" target. Change-Id: Ic44d9ffe5fa2d88f38c018756738197371b0dc89 Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ee8a91f500..cabb65f9d8 100644
--- a/meson.build
+++ b/meson.build
@@ -289,9 +289,14 @@ nghttp2 = dependency('libnghttp2', version: '>=1.52.0', required: false)
if not nghttp2.found()
cmake = import('cmake')
opt_var = cmake.subproject_options()
- opt_var.add_cmake_defines({'ENABLE_LIB_ONLY': true, 'ENABLE_STATIC_LIB': true})
+ opt_var.add_cmake_defines(
+ {
+ 'ENABLE_LIB_ONLY': true,
+ 'ENABLE_STATIC_LIB': true,
+ },
+ )
nghttp2_ex = cmake.subproject('nghttp2', options: opt_var)
- nghttp2 = nghttp2_ex.dependency('nghttp2_static')
+ nghttp2 = nghttp2_ex.dependency('nghttp2')
endif
bmcweb_dependencies += nghttp2