summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2023-06-28 21:28:38 +0300
committerEd Tanous <ed@tanous.net>2023-07-12 22:48:32 +0300
commit2c6ffdb08b2207ff7c31041f77cc3755508d45c4 (patch)
tree5b2b58102221318866a06a11751d2efa76782fe4 /meson.build
parent9eef578458f6dc3587bd27039f1ebb367041000b (diff)
downloadbmcweb-2c6ffdb08b2207ff7c31041f77cc3755508d45c4.tar.xz
Use openssl random number generator
We already have a generator class. We should use it. Wrap this into a function that can be unit tested, and add unit tests. Note, some files also needed to change name, because random.hpp conflicts with the built in random, and causes circular build problems. This commit changes it to ossl_random. Tested: Unit tests pass. Now has coverage. Redfish service validator passes. Change-Id: I5f8eee1af5f4843a352c6fd0e26d67fd3320ef53 Signed-off-by: Ed Tanous <edtanous@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dd8eb81855..e9716be153 100644
--- a/meson.build
+++ b/meson.build
@@ -355,6 +355,7 @@ srcfiles_bmcweb = files(
'src/boost_url.cpp',
'src/dbus_singleton.cpp',
'src/json_html_serializer.cpp',
+ 'src/ossl_random.cpp',
)
bmcweblib = static_library(
@@ -391,6 +392,7 @@ srcfiles_unittest = files(
'test/include/multipart_test.cpp',
'test/include/openbmc_dbus_rest_test.cpp',
'test/include/str_utility_test.cpp',
+ 'test/include/ossl_random.cpp',
'test/redfish-core/include/privileges_test.cpp',
'test/redfish-core/include/redfish_aggregator_test.cpp',
'test/redfish-core/include/registries_test.cpp',