summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-04-12 16:05:58 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-12 16:05:58 +0300
commit4efe3e0c02ed5d955175fd863a575e2709a6e461 (patch)
treebccaf322c7ceb86f6f0ad2d287a43287b6a05f2c /meson.build
parent7a2bb2c9561a57dd23d1de44f5f38a95fdd806af (diff)
downloadbmcweb-4efe3e0c02ed5d955175fd863a575e2709a6e461.tar.xz
meson: remove deprecated get_pkgconfig_variable
Since meson 0.56, the `get_pkgconfig_variable` has been deprecated. In meson 0.58 the `get_variable` was enhanced to no longer require the `pkgconfig` keyword argument. Ensure meson 0.58 is required and update the usage of all `get_pkgconfig_variable` and `get_variable` to be the modern variant. Change-Id: I61193ae9fb34cec80af60acef68ff643c392e29d Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 93ac8da9be..cf4c658aa7 100644
--- a/meson.build
+++ b/meson.build
@@ -305,7 +305,7 @@ if get_option('tests').enabled()
gmock = gmock.as_system('system')
endif
-systemd_system_unit_dir = systemd.get_variable(pkgconfig: 'systemdsystemunitdir')
+systemd_system_unit_dir = systemd.get_variable('systemdsystemunitdir')
bindir = get_option('prefix') + '/' +get_option('bindir')