summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2023-09-02 00:20:50 +0300
committerEd Tanous <ed@tanous.net>2023-12-05 21:54:28 +0300
commit4fa45dffd1ece21a468ed32850428b3b41bc8093 (patch)
treeda14af66150c4b652c8aeb5c42d1e5789ac04cdd /meson.build
parent7164bc62dd26ec92b01985aaae97ecc48276dea5 (diff)
downloadbmcweb-4fa45dffd1ece21a468ed32850428b3b41bc8093.tar.xz
Unit test Connection
Boost asio provides a test stream object that we can use to begin unit testing the connection object. This patchset uses it to re-enable some simple http1.1 tests. There's some features that have snuck into the connection class that aren't compatible with a stream (like ip address getting), so unfortunately we do need the connection class to be aware if it's in test mode, but that tradeoff seems worthwhile. Tested: Unit test pass. Change-Id: Id8b1f8866582b58502dbafe6139f841bf64b8ef3 Signed-off-by: Ed Tanous <edtanous@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e1ee9c35d5..541fa5e820 100644
--- a/meson.build
+++ b/meson.build
@@ -412,6 +412,7 @@ executable(
srcfiles_unittest = files(
'test/http/crow_getroutes_test.cpp',
+ 'test/http/http_connection_test.cpp',
'test/http/router_test.cpp',
'test/http/utility_test.cpp',
'test/http/verb_test.cpp',