summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2024-01-29 19:34:59 +0300
committerEd Tanous <ed@tanous.net>2024-02-16 20:34:04 +0300
commit52dd6932dea23ed6f6ae24caec12c9a7f19c2284 (patch)
tree386e7fed2b1343a3f38b99ee9f8f2b77437f95ff /meson.build
parentd088218997348f27272a61a7f892a2291a6c2d6d (diff)
downloadbmcweb-52dd6932dea23ed6f6ae24caec12c9a7f19c2284.tar.xz
Write unit tests for http2 connection
This unit test currently only tests a simple connect and settings frame transfer, but should form the basis for more complex testing in the future. Tested: Unit tests pass Change-Id: Ieb803dbe490129ec5fe99fb3d4505a06202e282e Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f260f86c28..6184f62ba4 100644
--- a/meson.build
+++ b/meson.build
@@ -422,6 +422,7 @@ executable(
srcfiles_unittest = files(
'test/http/crow_getroutes_test.cpp',
+ 'test/http/http2_connection_test.cpp',
'test/http/http_connection_test.cpp',
'test/http/mutual_tls.cpp',
'test/http/router_test.cpp',