summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2024-04-14 20:24:20 +0300
committerEd Tanous <ed@tanous.net>2024-04-16 22:24:44 +0300
commit6dbe9bea2e45791fc924645fb8b7813fdd7f4cd1 (patch)
treec358d457542fab95ed35490f229cfa37792387fa /meson.build
parent10cb44f3d47622faf795f8f09baef389cb0a6714 (diff)
downloadbmcweb-6dbe9bea2e45791fc924645fb8b7813fdd7f4cd1.tar.xz
Remove OpenSSL warnings ignore
If we include OpenSSL in extern "C" blocks consistently, c++ warnings no longer appear. This means we can remove the special case from meson. Tested: Code compiles when built locally on an ubuntu 22.04 system. Change-Id: I5add4113b32cd88b7fdd874174c845425a7c287a Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 1665946d85..5ffc18c535 100644
--- a/meson.build
+++ b/meson.build
@@ -265,11 +265,6 @@ if not openssl.found() or get_option('b_sanitize') != 'none'
)
openssl = openssl_proj.get_variable('openssl_dep')
openssl = openssl.as_system('system')
-else
- # When we build openssl as a subproject, the warnings analyzer starts
- # flagging all the C macros as old style casts, so only enable the
- # warning for non subprojects.
- add_project_arguments('-Wold-style-cast', language: 'cpp')
endif
bmcweb_dependencies += [openssl]