summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2024-01-28 20:49:03 +0300
committerEd Tanous <ed@tanous.net>2024-02-16 20:34:04 +0300
commit7a6f003180968fc578af8eee88b453a906efeed7 (patch)
treef1e871c02729317bdfb50896b4b253134f6db5cb /meson.build
parent52e31629978bbcefc0e14c96272ef77c2dad6a9c (diff)
downloadbmcweb-7a6f003180968fc578af8eee88b453a906efeed7.tar.xz
Add unit tests for file body
File body needs some unit tests for managing the move constructors. Tested: Unit tests pass. Change-Id: Ia640aec75a6f3f85640a50f5dd492638871f9eca Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d47bdb7e2d..f260f86c28 100644
--- a/meson.build
+++ b/meson.build
@@ -357,7 +357,7 @@ else
endif
if get_option('tests').allowed()
- gtest = dependency('gtest', main: true, disabler: true, required : false)
+ gtest = dependency('gtest', main: true, version: '>=1.14.0', disabler: true, required : false)
gmock = dependency('gmock', required : false)
if not gtest.found() and get_option('tests').allowed()
gtest_proj = subproject('gtest', required: true)
@@ -429,6 +429,7 @@ srcfiles_unittest = files(
'test/http/utility_test.cpp',
'test/http/verb_test.cpp',
'test/http/mutual_tls_meta.cpp',
+ 'test/http/http_file_body_test.cpp',
'test/include/dbus_utility_test.cpp',
'test/include/google/google_service_root_test.cpp',
'test/include/json_html_serializer.cpp',