summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2023-06-06 18:26:29 +0300
committerEd Tanous <ed@tanous.net>2023-06-06 19:08:02 +0300
commit982dd79d371c48f48ea1e3462545ac4e2a8b4f93 (patch)
treeb5c8a5322a1469e4c5e3ec22b52dbd924dba912c /meson.build
parent21b4aba40554549204a02d71a998379dc2ea44f4 (diff)
downloadbmcweb-982dd79d371c48f48ea1e3462545ac4e2a8b4f93.tar.xz
Change nlohmann to nlohmann_json
c9374ff613b6836010877f8083e75657abc78343 Was recently checked in that adds subproject files for nlohmann. It opted for the name "nlohmann" when the upstream project installs itself as "nlohmann_json". This mismatch causes a yocto build failure. Fix it. Tested: Code compiles Change-Id: I2df5f473a61172593e9a1045fc5a229e06e3afc2 Signed-off-by: Ed Tanous <edtanous@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index cdfc3dd962..e59eee9c21 100644
--- a/meson.build
+++ b/meson.build
@@ -282,9 +282,9 @@ systemd = dependency('systemd')
zlib = dependency('zlib')
bmcweb_dependencies += [systemd, zlib]
-nlohmann_json = dependency('nlohmann', version: '>=3.9.2', required: false, include_type: 'system')
+nlohmann_json = dependency('nlohmann_json', version: '>=3.9.2', required: false, include_type: 'system')
if not nlohmann_json.found()
- nlohmann_json_proj = subproject('nlohmann', required: true)
+ nlohmann_json_proj = subproject('nlohmann_json', required: true)
nlohmann_json = nlohmann_json_proj.get_variable('nlohmann_json_dep')
nlohmann_json = nlohmann_json.as_system('system')
endif