summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2023-10-19 20:19:51 +0300
committerEd Tanous <ed@tanous.net>2023-10-24 21:17:59 +0300
commitdb7b3876bc537dc927f162952e060d91ed1e3f7b (patch)
tree39fc6f82f2a2dd3f6157f59b53f5d26cea3acf02 /meson.build
parent26eee3a154f234d4cea80ba40a2091b739a60593 (diff)
downloadbmcweb-db7b3876bc537dc927f162952e060d91ed1e3f7b.tar.xz
Fix boost build locally
Change I1d00ef561fed7e3ba799969a112ee58b6578ce32 fixed local compilation of bmcweb, but it is causing failures when attempting to SRCREV bump. This should fix the issues during SRCREV bump while still allowing local builds to succeed. Tested (Carson): I was able to locally build bmcweb without having previously installed any boost libraries. All unit tests also passed. meson buildlocal && ninja -C buildlocal test Change-Id: I8cbb764dc564b84b4adb06ba80cb87b2a2c4701f Signed-off-by: Ed Tanous <edtanous@google.com> Signed-off-by: Carson Labrado <clabrado@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index e2754c563f..630fac6de3 100644
--- a/meson.build
+++ b/meson.build
@@ -310,14 +310,7 @@ bmcweb_dependencies += nlohmann_json
boost = dependency(
'boost',
modules: [
- 'asio',
- 'beast',
- 'callable_traits',
- 'headers',
- 'process',
- 'type_index',
'url',
- 'uuid'
],
version : '>=1.83.0',
required : false,