summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-12-07 20:50:37 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-12-07 21:09:36 +0300
commitdfd5547b98d0a7360ca6cfe8b48b9d7ce2cf95d2 (patch)
treebde0629a79fb96de5a5dae9a1018690060c3ec85 /meson.build
parent998e0cbdc5092bdaa783d11c2760bf62084403ce (diff)
downloadbmcweb-dfd5547b98d0a7360ca6cfe8b48b9d7ce2cf95d2.tar.xz
meson: adjust nlohmann-json dependency
* Simplify the meson.build boiler-plate for meson. * Rename the wrap file for consistency with other repositories. * Adjust the meson required version to match the wrap file. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I2da418c10fbe0450944567d276b17f3196da0b55
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 541fa5e820..f3e0ed3be8 100644
--- a/meson.build
+++ b/meson.build
@@ -300,13 +300,8 @@ systemd = dependency('systemd')
zlib = dependency('zlib')
bmcweb_dependencies += [systemd, zlib]
-nlohmann_json = dependency('nlohmann_json', version: '>=3.9.2', required: false, include_type: 'system')
-if not nlohmann_json.found()
- nlohmann_json_proj = subproject('nlohmann_json', required: true)
- nlohmann_json = nlohmann_json_proj.get_variable('nlohmann_json_dep')
- nlohmann_json = nlohmann_json.as_system('system')
-endif
-bmcweb_dependencies += nlohmann_json
+nlohmann_json_dep = dependency('nlohmann_json', version: '>=3.11.2', include_type: 'system')
+bmcweb_dependencies += nlohmann_json_dep
boost = dependency(
'boost',