summaryrefslogtreecommitdiff
path: root/config/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'config/meson.build')
-rw-r--r--config/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/config/meson.build b/config/meson.build
index 21da40e077..1c6f78a999 100644
--- a/config/meson.build
+++ b/config/meson.build
@@ -19,6 +19,10 @@ enable_multi_host = get_option('experimental-redfish-multi-computer-system')
conf_data.set10('BMCWEB_ENABLE_MULTI_HOST', enable_multi_host.allowed())
enable_http2 = get_option('experimental-http2')
conf_data.set10('BMCWEB_ENABLE_HTTP2', enable_http2.allowed())
+
+enable_tls = get_option('insecure-disable-ssl')
+conf_data.set10('BMCWEB_ENABLE_TLS', enable_tls.disabled())
+
conf_data.set10(
'BMCWEB_ENABLE_MTLS_COMMON_NAME_PARSING_META',
get_option('mutual-tls-common-name-parsing') == 'meta',