summaryrefslogtreecommitdiff
path: root/meta-amd
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2023-01-17 12:23:26 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-27 20:16:36 +0300
commit247630521f1d6a785c856bcecd931b30184297ca (patch)
tree197b8a9ac60527c83ced76a9d6e2c3f9a71debc1 /meta-amd
parent7988c1e685d448e36f53a4c0702adf964507ac33 (diff)
downloadopenbmc-247630521f1d6a785c856bcecd931b30184297ca.tar.xz
meta-ethanolx: Add JSON file for the x86-power-control
"x86-power-control" doesn't allow to set BMC_READY signal, but besides that everything is compatible with the upstream code. Change-Id: Ic60bfa7b7cbb85494c542fea9b3fd480beec0a12 Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Diffstat (limited to 'meta-amd')
-rw-r--r--meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control/power-config-host0.json58
-rw-r--r--meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend9
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control/power-config-host0.json b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control/power-config-host0.json
new file mode 100644
index 0000000000..0d0faf9200
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control/power-config-host0.json
@@ -0,0 +1,58 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "IdButton",
+ "LineName" : "CHASSIS_ID_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIButton",
+ "LineName" : "MON_P0_NMI_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIOut",
+ "LineName" : "ASSERT_NMI_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "PostComplete",
+ "LineName" : "MON_PWROK",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "PowerButton",
+ "LineName" : "MON_P0_PWR_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "PowerOk",
+ "LineName" : "MON_P0_PWR_GOOD",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "PowerOut",
+ "LineName" : "ASSERT_PWR_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "ResetButton",
+ "LineName" : "MON_P0_RST_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "ResetOut",
+ "LineName" : "ASSERT_RST_BTN",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ }
+]
+}
diff --git a/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000000..cba1306def
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://power-config-host0.json \
+ "
+
+do_install:append() {
+ install -d ${D}/${datadir}/${PN}
+ install -m 0644 ${WORKDIR}/power-config-host0.json ${D}/${datadir}/${PN}
+}