summaryrefslogtreecommitdiff
path: root/meta-amd
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2023-01-17 12:02:04 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-27 20:16:36 +0300
commit41d8435a8da033e7129c9fd2602054d9e7ba51b0 (patch)
tree4cfe1f6ce0c2f617f6861dedf624597ffddd51d9 /meta-amd
parent16a9a512ec9d7b7cb02cea1f1b7fc3d679b4813e (diff)
downloadopenbmc-41d8435a8da033e7129c9fd2602054d9e7ba51b0.tar.xz
meta-ethanolx: Enable ipmitool sol functionality
To enable Serial-Over-LAN functionality via the standard "ipmitool sol" command it is necessary to create a DBUS interface "xyz.openbmc_project.Ipmi.SOL" that would be used for the communication between the "phosphor-net-ipmid" and "phosphor-host-ipmid" applications. Change-Id: I41eaac0eb53b66d135032c14e69abbe5e97509ce Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Diffstat (limited to 'meta-amd')
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager/sol-default.override.yml17
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend4
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager/sol-default.override.yml b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager/sol-default.override.yml
new file mode 100644
index 0000000000..fe9d1e7265
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager/sol-default.override.yml
@@ -0,0 +1,17 @@
+/xyz/openbmc_project/ipmi/sol/eth0:
+ - Interface: xyz.openbmc_project.Ipmi.SOL
+ Properties:
+ AccumulateIntervalMS:
+ Default: 1
+ Enable:
+ Default: 'true'
+ Privilege:
+ Default: 4
+ Progress:
+ Default: 0
+ RetryCount:
+ Default: 7
+ RetryIntervalMS:
+ Default: 1
+ Threshold:
+ Default: 1
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
index f1c5acabc9..1d832ab56a 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -1 +1,5 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
PACKAGECONFIG:append:ethanolx = " boot_type"
+
+SRC_URI += " file://sol-default.override.yml"