summaryrefslogtreecommitdiff
path: root/meta-amd
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-03-24 17:38:10 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-03-27 18:00:06 +0300
commit677746180de48cdbdd0f103c10fa3ef735a17f36 (patch)
treea27dd4ad3264f8f3d11c2939feb64d1a4b2de9da /meta-amd
parentc7d880245bd260333a9f7eebbaec56a2a24ab53c (diff)
downloadopenbmc-677746180de48cdbdd0f103c10fa3ef735a17f36.tar.xz
treewide: switch '/usr/share' to datadir
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I8ea79d284356629f5b7b24ad3a99336e9e2e297e
Diffstat (limited to 'meta-amd')
-rw-r--r--meta-amd/meta-daytonax/recipes-phosphor/configuration/entity-manager_%.bbappend8
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend8
2 files changed, 8 insertions, 8 deletions
diff --git a/meta-amd/meta-daytonax/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-daytonax/recipes-phosphor/configuration/entity-manager_%.bbappend
index cab4272002..b1011c8ea9 100644
--- a/meta-amd/meta-daytonax/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-amd/meta-daytonax/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -4,9 +4,9 @@ SRC_URI:append = " file://daytonax-baseboard.json \
"
do_install:append() {
- rm -f ${D}/usr/share/entity-manager/configurations/*.json
- install -d ${D}/usr/share/entity-manager/configurations
- install -m 0444 ${WORKDIR}/daytonax-baseboard.json ${D}/usr/share/entity-manager/configurations
- install -m 0444 ${WORKDIR}/daytonax-chassis.json ${D}/usr/share/entity-manager/configurations
+ rm -f ${D}${datadir}/entity-manager/configurations/*.json
+ install -d ${D}${datadir}/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/daytonax-baseboard.json ${D}${datadir}/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/daytonax-chassis.json ${D}${datadir}/entity-manager/configurations
}
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
index f55bf23908..dc1d72822f 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -3,8 +3,8 @@ SRC_URI:append = " file://ethanolx-baseboard.json \
file://ethanolx-chassis.json"
do_install:append() {
- rm -f ${D}/usr/share/entity-manager/configurations/*.json
- install -d ${D}/usr/share/entity-manager/configurations
- install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}/usr/share/entity-manager/configurations
- install -m 0444 ${WORKDIR}/ethanolx-chassis.json ${D}/usr/share/entity-manager/configurations
+ rm -f ${D}${datadir}/entity-manager/configurations/*.json
+ install -d ${D}${datadir}/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}${datadir}/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-chassis.json ${D}${datadir}/entity-manager/configurations
}