summaryrefslogtreecommitdiff
path: root/meta-asrock
diff options
context:
space:
mode:
authorZev Weiss <zev@bewilderbeest.net>2023-11-07 06:57:52 +0300
committerZev Weiss <zev@bewilderbeest.net>2024-01-20 04:58:01 +0300
commitf5cc8dd7f2b05f0fe482b93792a42cc387a34f6d (patch)
treec57e722974114c8fcaf677b214144189b6c43635 /meta-asrock
parent7d461506196f2c5db738aaa35e0d2104fea61e07 (diff)
downloadopenbmc-f5cc8dd7f2b05f0fe482b93792a42cc387a34f6d.tar.xz
meta-asrock: e3c256d4i: Add obmc-console config
While on all other currently supported ASRock platforms the Aspeed VUART provides the host serial console, we haven't had any success using it over eSPI on e3c256d4i, so instead we're using a pair of SUARTs connected via the UART mux. This unforunately requires leaving the AST2500's built-in Super-IO enabled, because the host firmware needs to access it shortly after power-on in order to configure its UART output, so we also have to open up some of the u-boot backdoor config options too. Signed-off-by: Zev Weiss <zev@bewilderbeest.net> Change-Id: Ibdab607d504cebd956a7e23191c09cd0d5c44e50
Diffstat (limited to 'meta-asrock')
-rw-r--r--meta-asrock/meta-e3c256d4i/recipes-bsp/u-boot/files/e3c256d4i.cfg5
-rw-r--r--meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console/obmc-console.conf4
-rw-r--r--meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console_git.bbappend3
3 files changed, 12 insertions, 0 deletions
diff --git a/meta-asrock/meta-e3c256d4i/recipes-bsp/u-boot/files/e3c256d4i.cfg b/meta-asrock/meta-e3c256d4i/recipes-bsp/u-boot/files/e3c256d4i.cfg
index e0814cedc6..8bbe1b21c2 100644
--- a/meta-asrock/meta-e3c256d4i/recipes-bsp/u-boot/files/e3c256d4i.cfg
+++ b/meta-asrock/meta-e3c256d4i/recipes-bsp/u-boot/files/e3c256d4i.cfg
@@ -3,3 +3,8 @@
# glitches the line and resets the host; disabling the driver (which we don't
# need) prevents that.
CONFIG_MMC_SDHCI_ASPEED=n
+
+# Unfortunately the host needs access to the ast2500 Super-IO in order to
+# configure the UART for its serial console
+CONFIG_ASPEED_ALLOW_DANGEROUS_BACKDOORS=y
+CONFIG_ASPEED_ENABLE_SUPERIO=y
diff --git a/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 0000000000..84fbe60aab
--- /dev/null
+++ b/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,4 @@
+baud = 115200
+
+# Host uses UART2, BMC uses UART4
+aspeed-uart-routing = uart4:uart2 uart2:uart4
diff --git a/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console_git.bbappend b/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console_git.bbappend
new file mode 100644
index 0000000000..ba98fc2860
--- /dev/null
+++ b/meta-asrock/meta-e3c256d4i/recipes-phosphor/console/obmc-console_git.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+OBMC_CONSOLE_HOST_TTY = "ttyS3"