summaryrefslogtreecommitdiff
path: root/meta-fii
diff options
context:
space:
mode:
authorJonico Eustaquio <jonico.eustaquio@fii-na.com>2022-10-13 17:09:08 +0300
committerVivekanand Veeracholan <vveerach@google.com>2023-03-29 02:08:10 +0300
commitab6556b1d9ae763211659a58637607d55b12b1ea (patch)
tree28b6e289ddc7c6b21968a84ce84f50fbeeedd175 /meta-fii
parentd6f43352d7f6ce6385e028e9dae3974571266448 (diff)
downloadopenbmc-ab6556b1d9ae763211659a58637607d55b12b1ea.tar.xz
meta-fii: meta-mori: Remove dependency for mori bios verify
The dependency obmc-host-reboot target has on obmc-host-shutdown and phosphor-reboot-host must be removed to allow for the mori-bios-verify service. The mori-bios-verify service will have a 60s sleep that requires the host to hold its state for the 60s duration after it is commanded to powercycle. Without these dependencies removed, the host would shutdown immediately. Signed-off-by: Jonico Eustaquio <jonico.eustaquio@fii-na.com> Change-Id: If2df43c8276626a3623bd4e796d87ea6817c32c7
Diffstat (limited to 'meta-fii')
-rw-r--r--meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 03510cfacf..ce1fae3f69 100644
--- a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -14,6 +14,12 @@ pkg_postinst:${PN}-obmc-targets:prepend:mori() {
ln -s $TARGET $LINK
}
+pkg_postinst:${PN}-obmc-targets:append:mori() {
+ rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/obmc-host-shutdown@0.target"
+ rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/phosphor-reboot-host@0.service"
+}
+
+
pkg_prerm:${PN}-obmc-targets:prepend:mori() {
LINK="$D$systemd_system_unitdir/multi-user.target.requires/phosphor-host-condition-gpio@0.service"
rm $LINK