summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2024-03-29 21:09:17 +0300
committerBenjamin Fair <benjaminfair@google.com>2024-04-02 19:34:02 +0300
commit5da95ea567aa67b1db6a193940ef7cda9053ed80 (patch)
tree41b59b775ac71a6419f64859b026c5534ff82567 /meta-google
parentc6db9d3ca121e437672223517c149951498b8a97 (diff)
downloadopenbmc-5da95ea567aa67b1db6a193940ef7cda9053ed80.tar.xz
meta-google: phosphor-ipmi-config: Set mfg and prod IDs
This sets the manufacturer ID to Google's IANA enterprise number and the product ID to gBMC when building with the gbmc distro. Tested: Built gbs and inspected dev_id.json Signed-off-by: Benjamin Fair <benjaminfair@google.com> Change-Id: Ia0d07a36808732e4b15889165818eaed59945927
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 5eb36f1048..6e25fc2e2b 100644
--- a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -94,6 +94,9 @@ python do_gbmc_version () {
}
dev_id["aux"] = subpoint << 16 | (0xFFFF & point)
+ dev_id["manuf_id"] = 11129
+ dev_id["prod_id"] = 14426
+
with open(path, 'w') as f:
json.dump(dev_id, f, sort_keys=True, indent=4)
}