summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2023-10-19 02:09:29 +0300
committerWilliam A. Kennington III <wak@google.com>2023-10-27 00:46:45 +0300
commitbff90315fe326067ee38bf0deda829c7c3da3aaf (patch)
tree8dd9979a7700ad183ff4e1e2f4f4becf421aa53f /meta-google
parent38028f55fd1f8d4a9fdaeebb271a0a9d239285b1 (diff)
downloadopenbmc-bff90315fe326067ee38bf0deda829c7c3da3aaf.tar.xz
meta-google: phosphor-ipmi-config: Update NCSI interface name
Our configuration assumes the NCSI interface in slot 1 is eth0, let's update it to rewrite the interface name appropriately. Change-Id: Iecaaeac2e0a2ebc33b3b19d456de85f4e9ec48de Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 0250bda9ae..1afe115502 100644
--- a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -42,6 +42,9 @@ do_install:append:gbmc() {
exit 1
fi
gbmc_add_channel ${GBMCBR_IPMI_CHANNEL} gbmcbr
+ if [ -n "${GBMC_NCSI_IF_NAME}" ]; then
+ gbmc_add_channel 1 ${GBMC_NCSI_IF_NAME}
+ fi
# Set entity-map.json to empty json for gBMC by default.
# Each system will override it if needed.