summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorYuxiao Zhang <yuxiaozhang@google.com>2023-12-14 04:37:37 +0300
committerYuxiao Zhang <yuxiaozhang@google.com>2023-12-15 21:18:11 +0300
commitca818a384cbe9b1d0b62027113ad159d95d16e3b (patch)
tree6fd3cc41082e829f8e96d56a0fb26e505374573a /meta-google
parent123c246f33d19272d995ff5ddc473b17bdbed4eb (diff)
downloadopenbmc-ca818a384cbe9b1d0b62027113ad159d95d16e3b.tar.xz
meta-google: ipmi: add target for disabling ipmi in bare metal
Change-Id: Icb932ef7505f7177ff5b2b9bfeb2fd31352523eb Signed-off-by: Yuxiao Zhang <yuxiaozhang@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/ipmi/bare-metal-active.bb23
-rw-r--r--meta-google/recipes-google/ipmi/bare-metal-active/gbmc-bare-metal-active.target2
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ipmi/bare-metal-active.bb b/meta-google/recipes-google/ipmi/bare-metal-active.bb
new file mode 100644
index 0000000000..181b741887
--- /dev/null
+++ b/meta-google/recipes-google/ipmi/bare-metal-active.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Systemd target for enable/disable ipmi in bare-metal setup"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://gbmc-bare-metal-active.target"
+S = "${WORKDIR}"
+
+DEPENDS += " \
+ systemd \
+ "
+
+inherit systemd
+
+SYSTEMD_SERVICE:${PN} += " \
+ gbmc-bare-metal-active.target \
+ "
+
+do_install() {
+ install -d -m0755 ${D}${systemd_system_unitdir}
+ install -m0644 ${WORKDIR}/gbmc-bare-metal-active.target ${D}${systemd_system_unitdir}/
+}
diff --git a/meta-google/recipes-google/ipmi/bare-metal-active/gbmc-bare-metal-active.target b/meta-google/recipes-google/ipmi/bare-metal-active/gbmc-bare-metal-active.target
new file mode 100644
index 0000000000..736aed3ddd
--- /dev/null
+++ b/meta-google/recipes-google/ipmi/bare-metal-active/gbmc-bare-metal-active.target
@@ -0,0 +1,2 @@
+[Unit]
+Description=Untrusted customer OS is running on host CPU