summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorCharles Kearney <charles.kearney@hpe.com>2023-05-30 22:32:08 +0300
committerJean-Marie Verdun <jean-marie.verdun@hpe.com>2023-07-05 20:14:07 +0300
commit07fcf806b6d76608d49b6f3cb26fef27eca8a195 (patch)
treed048f23b59f682ba1cf0dd61c6f324b97d4b0737 /meta-hpe
parent9c7fd7172444cfa4d0b243a8be741ac38e123eaa (diff)
downloadopenbmc-07fcf806b6d76608d49b6f3cb26fef27eca8a195.tar.xz
meta-hpe: rl300-g11 add x86 power control bb append
Change-Id: Ia295013033424e0a973c8314b56b52b46c055a71 Signed-off-by: Charles Kearney <charles.kearney@hpe.com>
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control/power-config-host0.json91
-rw-r--r--meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control_%.bbappend9
2 files changed, 100 insertions, 0 deletions
diff --git a/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control/power-config-host0.json b/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control/power-config-host0.json
new file mode 100644
index 0000000000..ac565abe4b
--- /dev/null
+++ b/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control/power-config-host0.json
@@ -0,0 +1,91 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "IdButton",
+ "LineName" : "ID_BUTTON",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIButton",
+ "LineName" : "NMI_BUTTON",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIOut",
+ "LineName" : "NMI_OUT",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "PowerButton",
+ "DbusName" : "xyz.openbmc_project.Chassis.Gpios",
+ "Path" : "/xyz/openbmc_project/chassis/gpios",
+ "Interface" : "xyz.openbmc_project.Chassis.Gpios",
+ "Property" : "PButton",
+ "Type" : "DBUS"
+ },
+ {
+ "Name" : "PowerOk",
+ "DbusName" : "xyz.openbmc_project.Chassis.Gpios",
+ "Path" : "/xyz/openbmc_project/chassis/gpios",
+ "Interface" : "xyz.openbmc_project.Chassis.Gpios",
+ "Property" : "PGood",
+ "Type" : "DBUS"
+ },
+ {
+ "Name" : "PowerOut",
+ "LineName" : "POWER_OUT",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "ResetButton",
+ "LineName" : "RESET_BUTTON",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESET_OUT",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "SioOnControl",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "SioPowerGood",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "SIOS5",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ }
+],
+ "timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000
+ }
+}
diff --git a/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control_%.bbappend b/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control_%.bbappend
new file mode 100644
index 0000000000..6de157db42
--- /dev/null
+++ b/meta-hpe/meta-rl300-g11/recipes-x86/x86-power-control/x86-power-control_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://power-config-host0.json"
+
+do_configure:prepend() {
+cp ${WORKDIR}/power-config-host0.json ${S}/power-control-x86/config
+}
+
+