summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorMatt Fischer <matthew.fischer@hpe.com>2024-01-18 00:33:40 +0300
committerMatt Fischer <matt.fischer@hpe.com>2024-02-14 20:24:14 +0300
commitde0c27ed80e102b14d4e8dbec9020380fb0b4369 (patch)
treedc08da5d099416eb5e723f7ace18ba34b8f89a1a /meta-hpe
parent1f197f6cc4e779ee22706c15e0186f850bae22b1 (diff)
downloadopenbmc-de0c27ed80e102b14d4e8dbec9020380fb0b4369.tar.xz
meta-hpe: Fix permissions on systemd service file
systemd will complain if service files are executable. This generates a warning on every boot. The fix is to drop the execute bit. Here is the error that this remediates: systemd[1]: Configuration file /usr/lib/systemd/system/start-ipkvm.service is marked executable. Please remove executable permission bits. Proceeding anyway. Change-Id: I4ad9847aa6456823c5b34a18d26de2b3750ec262 Signed-off-by: Matt Fischer <matthew.fischer@hpe.com>
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-common/recipes-phosphor/recipes-graphics/obmc-ikvm_git.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-hpe/meta-common/recipes-phosphor/recipes-graphics/obmc-ikvm_git.bbappend b/meta-hpe/meta-common/recipes-phosphor/recipes-graphics/obmc-ikvm_git.bbappend
index 25fd08e224..97d4ca39f0 100644
--- a/meta-hpe/meta-common/recipes-phosphor/recipes-graphics/obmc-ikvm_git.bbappend
+++ b/meta-hpe/meta-common/recipes-phosphor/recipes-graphics/obmc-ikvm_git.bbappend
@@ -8,6 +8,6 @@ FILES:${PN} += " \
"
do_install:append () {
- install -D -m 0755 ${WORKDIR}/start-ipkvm.service ${D}${systemd_system_unitdir}
+ install -D -m 0644 ${WORKDIR}/start-ipkvm.service ${D}${systemd_system_unitdir}
install -D -m 0755 ${WORKDIR}/create_usbhid.sh ${D}${bindir}
-} \ No newline at end of file
+}