summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorjinuthomas <jinu.joy.thomas@in.ibm.com>2023-12-07 07:14:07 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-12-13 20:56:21 +0300
commit6e6226ba9ace845116e3604056fe93ebc256681e (patch)
tree8dc88461657a150944c330f11c6024d38c50c9f0 /meta-ibm
parent210e6b9e4bc0399fc91c1bb62120bec0071ab658 (diff)
downloadopenbmc-6e6226ba9ace845116e3604056fe93ebc256681e.tar.xz
meta-ibm: system1: add phosphor-buttons
Add phosphor-buttons to use the standard GPIOs to power on/off the machine when the user presses the power button on the system Also added the GPIO definition for the power button based on the GPIO it is connected seen in the schematics. Change-Id: I62e5179de37042020de016cc7b44afbe08e5638f Signed-off-by: Jinu Joy Thomas <jinu.joy.thomas@in.ibm.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-system1/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/skeleton/obmc-libobmc-intf/system1/gpio_defs.json5
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-ibm/meta-system1/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-system1/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 4af371ef17..23ceecf599 100644
--- a/meta-ibm/meta-system1/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-system1/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -12,6 +12,8 @@ RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
SUMMARY:${PN}-chassis = "OpenPOWER Chassis"
RDEPENDS:${PN}-chassis = " \
+ obmc-phosphor-buttons-signals \
+ obmc-phosphor-buttons-handler \
phosphor-power-control \
phosphor-skeleton-control-power \
"
diff --git a/meta-ibm/recipes-phosphor/skeleton/obmc-libobmc-intf/system1/gpio_defs.json b/meta-ibm/recipes-phosphor/skeleton/obmc-libobmc-intf/system1/gpio_defs.json
index b5c9aa1a26..ef09c7540d 100644
--- a/meta-ibm/recipes-phosphor/skeleton/obmc-libobmc-intf/system1/gpio_defs.json
+++ b/meta-ibm/recipes-phosphor/skeleton/obmc-libobmc-intf/system1/gpio_defs.json
@@ -15,6 +15,11 @@
"name": "PGOOD",
"pin": "V3",
"direction": "in"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "X6",
+ "direction": "in"
}
]
}