summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2023-08-21 23:40:13 +0300
committerJason Bills <jason.m.bills@linux.intel.com>2023-08-25 20:56:10 +0300
commitbf440f143d6d858dcd4e0e0f2fcc76de98c2f003 (patch)
tree07b506b5ecbb7e08458ceddbb46d141727888fc3 /meta-intel-openbmc
parent785c780867e27dd1d1dd2d05a9d18f6bdf5a557f (diff)
downloadopenbmc-bf440f143d6d858dcd4e0e0f2fcc76de98c2f003.tar.xz
host-error-monitor: switch to meson
This changes the build to meson and creates PACKAGECONFIGs for the build options to avoid needing to use EXTRA_OEMESON in recipes. Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com> Change-Id: Ifdbfecef46d16a5f36b03ee3a72eef30b9bc1b8b
Diffstat (limited to 'meta-intel-openbmc')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
index 06426b1871..e6c8c573c3 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -1,6 +1,10 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake pkgconfig systemd
+inherit meson pkgconfig systemd
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libpeci] = "-Dlibpeci=enabled,-Dlibpeci=disabled"
+PACKAGECONFIG[crashdump] = "-Dcrashdump=enabled,-Dcrashdump=disabled"
SRC_URI = "git://github.com/openbmc/host-error-monitor;branch=master;protocol=https"
@@ -12,5 +16,3 @@ SRCREV = "5e1e7e3c4fb6ba9f47d62ec9c053ee6b7f80e456"
S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.HostErrorMonitor.service"
-
-EXTRA_OECMAKE = "-DYOCTO=1"