summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2023-12-14 09:17:40 +0300
committerTim Lee <chli30@nuvoton.com>2024-01-10 04:06:41 +0300
commit7831b5e15714160276e5dc49fd0432ab58e7f82a (patch)
tree48a29038e32e02586fefc74a350ac4add6a10e45 /meta-nuvoton
parentf286638e507a3c9523b4c754bab2e7002b5e3413 (diff)
downloadopenbmc-7831b5e15714160276e5dc49fd0432ab58e7f82a.tar.xz
meta-nuvoton: add YAML configurations for evb-npcm845
Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: Id97b390d735f0df873b7ed479d24391d6c86d582
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config.bb35
-rw-r--r--meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru-properties.yaml7
-rw-r--r--meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru.yaml38
-rw-r--r--meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-inventory-sensors.yaml75
-rw-r--r--meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-sensors.yaml131
5 files changed, 286 insertions, 0 deletions
diff --git a/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config.bb b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config.bb
new file mode 100644
index 0000000000..a70deaad08
--- /dev/null
+++ b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config.bb
@@ -0,0 +1,35 @@
+SUMMARY = "YAML configuration for EVB NPCM845"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+SRC_URI:evb-npcm845 = " \
+ file://evb-npcm845-ipmi-fru.yaml \
+ file://evb-npcm845-ipmi-fru-properties.yaml \
+ file://evb-npcm845-ipmi-sensors.yaml \
+ file://evb-npcm845-ipmi-inventory-sensors.yaml \
+ "
+
+S = "${WORKDIR}"
+
+do_install:evb-npcm845() {
+ install -m 0644 -D evb-npcm845-ipmi-fru-properties.yaml \
+ ${D}${datadir}/${BPN}/ipmi-extra-properties.yaml
+ install -m 0644 -D evb-npcm845-ipmi-fru.yaml \
+ ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
+ install -m 0644 -D evb-npcm845-ipmi-sensors.yaml \
+ ${D}${datadir}/${BPN}/ipmi-sensors.yaml
+ install -m 0644 -D evb-npcm845-ipmi-inventory-sensors.yaml \
+ ${D}${datadir}/${BPN}/ipmi-inventory-sensors.yaml
+}
+
+FILES:${PN}-dev = " \
+ ${datadir}/${BPN}/ipmi-extra-properties.yaml \
+ ${datadir}/${BPN}/ipmi-fru-read.yaml \
+ ${datadir}/${BPN}/ipmi-sensors.yaml \
+ ${datadir}/${BPN}/ipmi-inventory-sensors.yaml \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru-properties.yaml b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru-properties.yaml
new file mode 100644
index 0000000000..d6f6a41c26
--- /dev/null
+++ b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru-properties.yaml
@@ -0,0 +1,7 @@
+/system/chassis/motherboard/management_card/bmc:
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'true'
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'true'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
diff --git a/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru.yaml b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru.yaml
new file mode 100644
index 0000000000..df481c65d2
--- /dev/null
+++ b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-fru.yaml
@@ -0,0 +1,38 @@
+1:
+ /system/chassis/motherboard/management_card/bmc:
+ entityID: 7
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+ xyz.openbmc_project.Common.UUID:
+ UUID:
+ IPMIFruProperty: Custom Field 1
+ IPMIFruSection: Board
+ IPMIFruValueDelimiter: 58
+ xyz.openbmc_project.Inventory.Item.Board:
+ xyz.openbmc_project.Inventory.Item.Bmc:
+ xyz.openbmc_project.Inventory.Item.NetworkInterface:
+ MACAddress:
+ IPMIFruProperty: Custom Field 2
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Ethernet:
diff --git a/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-inventory-sensors.yaml b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-inventory-sensors.yaml
new file mode 100644
index 0000000000..4dddd79229
--- /dev/null
+++ b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-inventory-sensors.yaml
@@ -0,0 +1,75 @@
+/xyz/openbmc_project/sensors/temperature/EVB_Temp:
+ eventReadingType: 1
+ sensorID: 0x01
+ sensorType: 1
+ offset: 0xff
+/xyz/openbmc_project/sensors/temperature/BMC_CPU_Temp0:
+ eventReadingType: 1
+ sensorID: 0x02
+ sensorType: 1
+ offset: 0xff
+/xyz/openbmc_project/sensors/temperature/BMC_CPU_Temp1:
+ eventReadingType: 1
+ sensorID: 0x03
+ sensorType: 1
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC1:
+ eventReadingType: 1
+ sensorID: 0x04
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC2:
+ eventReadingType: 1
+ sensorID: 0x05
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC3:
+ eventReadingType: 1
+ sensorID: 0x06
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC4:
+ eventReadingType: 1
+ sensorID: 0x07
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC5:
+ eventReadingType: 1
+ sensorID: 0x08
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC6:
+ eventReadingType: 1
+ sensorID: 0x09
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC7:
+ eventReadingType: 1
+ sensorID: 0x0A
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/voltage/ADC8:
+ eventReadingType: 1
+ sensorID: 0x0B
+ sensorType: 2
+ offset: 0xff
+/xyz/openbmc_project/sensors/fan_tach/Fan1:
+ eventReadingType: 1
+ sensorID: 0x0C
+ sensorType: 4
+ offset: 0xff
+/xyz/openbmc_project/sensors/fan_tach/Fan2:
+ eventReadingType: 1
+ sensorID: 0x0D
+ sensorType: 4
+ offset: 0xff
+/xyz/openbmc_project/sensors/fan_tach/Fan3:
+ eventReadingType: 1
+ sensorID: 0x0E
+ sensorType: 4
+ offset: 0xff
+/xyz/openbmc_project/sensors/fan_tach/Fan4:
+ eventReadingType: 1
+ sensorID: 0x0F
+ sensorType: 4
+ offset: 0xff \ No newline at end of file
diff --git a/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-sensors.yaml b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-sensors.yaml
new file mode 100644
index 0000000000..04efe8b1ec
--- /dev/null
+++ b/meta-nuvoton/meta-evb-npcm845/recipes-phosphor/configuration/evb-npcm845-yaml-config/evb-npcm845-ipmi-sensors.yaml
@@ -0,0 +1,131 @@
+# y = L[(M*x + (B * 10^K1)) * 10^K2]units
+# x: raw value
+# y: real value
+# M: multiplierM
+# B: offsetB
+# K1: bExp
+# K2: rExp
+
+1: &temperature
+ entityID: 0x07
+ entityInstance: 1
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/EVB_Temp
+ sensorReadingType: 0x01
+ multiplierM: 1
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: double
+2:
+ <<: *temperature
+ entityInstance: 2
+ path: /xyz/openbmc_project/sensors/temperature/BMC_CPU_Temp0
+3:
+ <<: *temperature
+ entityInstance: 3
+ path: /xyz/openbmc_project/sensors/temperature/BMC_CPU_Temp1
+
+4: &voltage
+ entityID: 0x07
+ entityInstance: 4
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/ADC1
+ sensorReadingType: 0x01
+ multiplierM: 157
+ offsetB: 0
+ bExp: 0
+ rExp: -4
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ sensorNamePattern: nameLeaf
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: double
+
+5:
+ <<: *voltage
+ entityInstance: 5
+ path: /xyz/openbmc_project/sensors/voltage/ADC2
+
+6:
+ <<: *voltage
+ entityInstance: 6
+ path: /xyz/openbmc_project/sensors/voltage/ADC3
+
+7:
+ <<: *voltage
+ entityInstance: 7
+ path: /xyz/openbmc_project/sensors/voltage/ADC4
+
+8:
+ <<: *voltage
+ entityInstance: 8
+ path: /xyz/openbmc_project/sensors/voltage/ADC5
+
+9:
+ <<: *voltage
+ entityInstance: 9
+ path: /xyz/openbmc_project/sensors/voltage/ADC6
+
+10:
+ <<: *voltage
+ entityInstance: 10
+ path: /xyz/openbmc_project/sensors/voltage/ADC7
+
+11:
+ <<: *voltage
+ entityInstance: 11
+ path: /xyz/openbmc_project/sensors/voltage/ADC8
+
+12: &fan_tach
+ entityID: 0x1D
+ entityInstance: 1
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan1
+ sensorReadingType: 0x01
+ multiplierM: 80
+ offsetB: 0
+ bExp: 0
+ rExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ mutability: Mutability::Read
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: double
+
+13:
+ <<: *fan_tach
+ entityInstance: 2
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan2
+
+14:
+ <<: *fan_tach
+ entityInstance: 3
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan3
+
+15:
+ <<: *fan_tach
+ entityInstance: 4
+ path: /xyz/openbmc_project/sensors/fan_tach/Fan4 \ No newline at end of file