summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2023-11-08 12:20:35 +0300
committerTim Lee <chli30@nuvoton.com>2023-11-09 08:54:48 +0300
commit96c32034564c6080293a94f9e932d21d73d494d3 (patch)
tree375bdf97ad8f0e516bb3605ad8ffb3c93125662e /meta-nuvoton
parentc9f4efb3d6189b5f3f1d91198bab28270a383d43 (diff)
downloadopenbmc-96c32034564c6080293a94f9e932d21d73d494d3.tar.xz
meta-nuvoton: npcm8xx-tip-fw: update to 0.6.5.0.5.4
Changelog: TIP_FW: 0.6.5 L0 0.5.4 L1 ============== * MC reset, if needed, performed synchronously from TIP side while BMC is in reset. Add new variable SA_TIP_IMAGE for supporing SA TIP_FW mimic no_tip mode. SA (Stand Alone) is a special TIP_FW for mimic NO TIP feature on TIP devices. That's concatenated file image_no_tip + SA FW for mimic NO TIP mode. Tested: Build pass and boot up successful with correct TIP FW latest version. Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: Ib836cf16f0f14f313b5243e18e8d615e792408b5
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/conf/machine/include/npcm8xx.inc3
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc2
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.5.0.5.4.bb (renamed from meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.4.0.5.3.bb)2
3 files changed, 6 insertions, 1 deletions
diff --git a/meta-nuvoton/conf/machine/include/npcm8xx.inc b/meta-nuvoton/conf/machine/include/npcm8xx.inc
index 086b5d19f8..1605363a0b 100644
--- a/meta-nuvoton/conf/machine/include/npcm8xx.inc
+++ b/meta-nuvoton/conf/machine/include/npcm8xx.inc
@@ -31,6 +31,7 @@ OPTEE_ALIGN ?= "4096"
UBOOT_ALIGN ?= "4096"
ALIGN_END ?= "4096"
PAD_ALIGN ?= "32"
+SA_ALIGN ?= "524288"
SOC_FAMILY = "npcm8xx"
include conf/machine/include/soc-family.inc
@@ -57,3 +58,5 @@ OPTEEMACHINE ?= "nuvoton"
SECURED_IMAGE ?= "True"
TIP_IMAGE ?= "True"
+
+SA_TIP_IMAGE ?= "False"
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
index 6a9983ac52..8a1750ab41 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
@@ -5,6 +5,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f789971f29c65e31dbb33ed209b4dc91"
TIP_FW = "Kmt_TipFwL0_Skmt_TipFwL1.bin"
+SA_TIP_FW = "SA_Kmt_TipFwL0.bin"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/Nuvoton-Israel/npcm8xx-tip-fw;branch=main;protocol=https"
@@ -12,6 +13,7 @@ SRC_URI = "git://github.com/Nuvoton-Israel/npcm8xx-tip-fw;branch=main;protocol=h
inherit deploy
do_deploy () {
install -D -m 644 ${OUTPUT_BIN}/${TIP_FW} ${DEPLOYDIR}/${TIP_FW}
+ install -D -m 644 ${OUTPUT_BIN}/${SA_TIP_FW} ${DEPLOYDIR}/${SA_TIP_FW}
}
addtask deploy before do_build after do_compile
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.4.0.5.3.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.5.0.5.4.bb
index 44047bfbe7..bf7acc1864 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.4.0.5.3.bb
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.6.5.0.5.4.bb
@@ -1,4 +1,4 @@
-SRCREV = "4d8c0b36cdb6bdd227a6e5a7a0f53cd16c141de3"
+SRCREV = "a01f053b639e6665c392e720eeab73edabe0d8d9"
OUTPUT_BIN = "output_binaries_${DEVICE_GEN}_${IGPS_MACHINE}"