summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorArchana Kakani <archana.kakani@ibm.com>2024-04-12 10:28:50 +0300
committerManojKiran Eda <manojkiran.eda@gmail.com>2024-05-14 15:42:51 +0300
commit9e6dedfe917beb760d1a4ad0f8e107d00e3e0f19 (patch)
tree204265ba0cf44c340ef19db8690640bf77f4723f /meta-phosphor
parent07d6121bdbe8de884cc0136dbf49d3882312c233 (diff)
downloadopenbmc-9e6dedfe917beb760d1a4ad0f8e107d00e3e0f19.tar.xz
meta-phosphor: Add system-specific-bios-json build option
The PLDM BIOS specification [1] defines data structures and messages for communicating BIOS settings, BIOS attributes, boot configurations, and boot order settings. The BIOS attributes supported by OpenBMC systems are added in JSON files, adhering to the specifications outlined in the BIOS Management Profile [2]. Since a single BIOS attribute may have different values for different variants of systems, it's practical to create a BIOS attribute JSON file for each system type. To enable this optional feature within PLDM, creating build option system-specific-bios-json. System specific bios attributes support in PLDM is added in below commits https://gerrit.openbmc.org/c/openbmc/pldm/+/55997 https://gerrit.openbmc.org/c/openbmc/pldm/+/69371 https://gerrit.openbmc.org/c/openbmc/pldm/+/70083 [1]: https://www.dmtf.org/sites/default/files/standards/documents/DSP1061_1.0.0.pdf [2]: https://www.dmtf.org/sites/default/files/standards/documents/DSP0247_1.0.0.pdf Change-Id: I372715e83232cd49cca4d33835da4c7c9b3d59c8 Signed-off-by: Archana Kakani <archana.kakani@ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 2df87e920f..e1176e4202 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -27,6 +27,7 @@ inherit systemd
PACKAGECONFIG[transport-mctp-demux] = "-Dtransport-implementation=mctp-demux"
PACKAGECONFIG[transport-af-mctp] = "-Dtransport-implementation=af-mctp"
PACKAGECONFIG[oem-ibm] = "-Doem-ibm=enabled, -Doem-ibm=disabled, , squashfs-tools"
+PACKAGECONFIG[system-specific-bios-json] = "-Dsystem-specific-bios-json=enabled, -Dsystem-specific-bios-json=disabled"
PACKAGECONFIG ??= ""
PACKAGECONFIG:append:df-mctp = " transport-af-mctp"