summaryrefslogtreecommitdiff
path: root/meta-qualcomm
diff options
context:
space:
mode:
authorJae Hyun Yoo <quic_jaehyoo@quicinc.com>2021-12-17 23:35:23 +0300
committerJae Hyun Yoo <quic_jaehyoo@quicinc.com>2022-08-18 22:06:31 +0300
commit84e4cfe4c0d3986a5c7ad58ce87d316624bcc4b3 (patch)
tree43ad6d10761b33248c26a17e390593e87361dff6 /meta-qualcomm
parent9a0e9eec7e713dd85d9559b90721b5d2d137f904 (diff)
downloadopenbmc-84e4cfe4c0d3986a5c7ad58ce87d316624bcc4b3.tar.xz
meta-qualcomm: linux-aspeed: enable Qualcomm specific kernel configs
Enable USB virtual HUB, HID and Mass Storage gadget configs. Disable USB host feature configs. Enable Micrel PHY support. Tested: Above Kernel features were enabled as expected. Signed-off-by: Jae Hyun Yoo <quic_jaehyoo@quicinc.com> Signed-off-by: Graeme Gregory <quic_ggregory@quicinc.com> Change-Id: Icefe69542d82666d1df3c198b3c1e00d32392842
Diffstat (limited to 'meta-qualcomm')
-rw-r--r--meta-qualcomm/recipes-kernel/linux/linux-aspeed/qualcomm.cfg19
-rw-r--r--meta-qualcomm/recipes-kernel/linux/linux-aspeed_%.bbappend3
-rw-r--r--meta-qualcomm/recipes.txt1
3 files changed, 23 insertions, 0 deletions
diff --git a/meta-qualcomm/recipes-kernel/linux/linux-aspeed/qualcomm.cfg b/meta-qualcomm/recipes-kernel/linux/linux-aspeed/qualcomm.cfg
new file mode 100644
index 0000000000..a97684f9ab
--- /dev/null
+++ b/meta-qualcomm/recipes-kernel/linux/linux-aspeed/qualcomm.cfg
@@ -0,0 +1,19 @@
+CONFIG_MICREL_PHY=y
+CONFIG_USB_GADGET_VBUS_DRAW=2
+CONFIG_USB_GADGET_STORAGE_NUM_BUFFERS=2
+CONFIG_USB_LIBCOMPOSITE=y
+CONFIG_USB_F_HID=y
+CONFIG_USB_GADGET=y
+CONFIG_U_SERIAL_CONSOLE=y
+CONFIG_USB_ASPEED_VHUB=y
+CONFIG_USB_MASS_STORAGE=y
+CONFIG_USB_CONFIGFS=y
+CONFIG_USB_CONFIGFS_MASS_STORAGE=y
+CONFIG_USB_CONFIGFS_F_FS=y
+CONFIG_USB_CONFIGFS_F_HID=y
+CONFIG_USB=n
+CONFIG_USB_ANNOUNCE_NEW_DEVICES=n
+CONFIG_USB_DYNAMIC_MINORS=n
+CONFIG_USB_EHCI_HCD=n
+CONFIG_USB_EHCI_ROOT_HUB_TT=n
+CONFIG_USB_EHCI_HCD_PLATFORM=n
diff --git a/meta-qualcomm/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-qualcomm/recipes-kernel/linux/linux-aspeed_%.bbappend
new file mode 100644
index 0000000000..d354d72ae7
--- /dev/null
+++ b/meta-qualcomm/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-aspeed:"
+
+SRC_URI:append = " file://qualcomm.cfg"
diff --git a/meta-qualcomm/recipes.txt b/meta-qualcomm/recipes.txt
index af029ab575..d8d3b686dc 100644
--- a/meta-qualcomm/recipes.txt
+++ b/meta-qualcomm/recipes.txt
@@ -1,2 +1,3 @@
recipes-core - core recipe modifications
+recipes-kernel - kernel recipe modifications
recipes-phospor - phosphor recipe modifications