summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-05-18 21:43:10 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-05-18 21:45:20 +0300
commit1d3ca46bd63f8e32a18f2ece930eab86e8f7a18d (patch)
treec1660b503c68c8298c971bafc2b851fd7f66484d /meta-quanta
parent57f354efd8592defa6ab597277c11f4bdecaa3fd (diff)
downloadopenbmc-1d3ca46bd63f8e32a18f2ece930eab86e8f7a18d.tar.xz
meta-gsj: fix do_install for usrmerge
The recipe previously had a hard coded removal of `/lib` which will no longer exist under usrmerge. I think the purpose of this was to delete the systemd units, but leave the library. Therefore I've adjusted the removal to be systemd_unitdir instead of `/lib`. This results in the following package structure: ``` $ find tmp/work/armv7a-openbmc-linux-gnueabi/google-ipmi-sys/0.1+gitAUTOINC+59445f5e21-r1/packages-split/google-ipmi-sys -type f tmp/work/armv7a-openbmc-linux-gnueabi/google-ipmi-sys/0.1+gitAUTOINC+59445f5e21-r1/packages-split/google-ipmi-sys/usr/lib/systemd/system-preset/98-google-ipmi-sys.preset tmp/work/armv7a-openbmc-linux-gnueabi/google-ipmi-sys/0.1+gitAUTOINC+59445f5e21-r1/packages-split/google-ipmi-sys/usr/lib/ipmid-providers/libgooglesys.so ``` The `98-google-ipmi-sys.preset` file is empty. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I05dd016fcc8dfd8dc33ba90acad100afafb18073
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend b/meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend
index 90200fe73a..651cf2d797 100644
--- a/meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend
@@ -6,5 +6,5 @@ SYSTEMD_SERVICE:${PN}:remove:gsj = " \
"
do_install:append:gsj() {
- rm -r ${D}/lib
+ rm -r ${D}${systemd_unitdir}
}