summaryrefslogtreecommitdiff
path: root/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 16:57:07 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 17:06:20 +0300
commitc7d1cd9477b2f14e48524da420e1528f6036c8b6 (patch)
tree22c0f5f735b505b82610cc0f8190aae12a80347e /meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
parentef2307412f38a174f511852bedcbe9974e68674d (diff)
downloadopenbmc-c7d1cd9477b2f14e48524da420e1528f6036c8b6.tar.xz
meta-amd: subtree update:0ec4f9ff17..496d83825e
Supreeth Venkatesh (22): meta-amd: Add recipe for power control. meta-amd: Override watchdog recipe. meta-amd: Override fans and sel-logger recipes. meta-amd: Define OpenBMC AMD package group applications. meta-amd: Add Linux kernel recipe for EthanolX. meta-amd: EthanolX platform configuration meta-amd: Enable bmcweb and phosphor-webui meta-amd: Enable LED Group Management for Ethanolx meta-amd: Enable OOB BMC firmware update meta-amd: Enable SOL host console meta-amd: Modify device tree to enable thermal sensors for EthanolX meta-amd: Enable hwmon to monitor thermal sensors and fan meta-amd: Enable ipmi fru and sensor configuration meta-amd: Add ipmi config, host and fru .bbappend files meta-amd: Add entity-manager and ipmitool modules meta-amd:linux: Added I2c0 and I2c1 which cater to AMD's APML Interface meta-amd: Remove device tree patch meta-amd: Add device tree patch meta-amd: Add chassis control application meta-amd: Add phosphor host logger application meta-amd: Add fan tach sensor for fan 0 and fan 1 meta-amd: Remove bmcweb bbappend file Change-Id: I53d6f4be203eefce1475d588b55fdf785b2b2024 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-amd/meta-ethanolx/conf/machine/ethanolx.conf')
-rw-r--r--meta-amd/meta-ethanolx/conf/machine/ethanolx.conf39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf b/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
new file mode 100644
index 000000000..7469c9a1c
--- /dev/null
+++ b/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
@@ -0,0 +1,39 @@
+
+KMACHINE = "aspeed"
+KERNEL_DEVICETREE = "${KMACHINE}-bmc-amd-${MACHINE}.dtb"
+
+UBOOT_MACHINE_ethanolx = "ast_g5_phy_config"
+
+require conf/machine/include/ast2500.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+SERIAL_CONSOLES = "115200;ttyS4"
+
+FLASH_SIZE = "32768"
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-bmc-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-host-state-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-host-ipmi \
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-flash-mgmt \
+ "
+
+VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
+VIRTUAL-RUNTIME_obmc-host-state-manager ?= "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager ?= "x86-power-control"
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-amd-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-amd-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-amd-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw ?= "phosphor-ipmi-kcs"
+PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-amd-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
+PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "ethanolx-led-manager-config-native"
+
+OVERRIDES .= ":amd"
+
+