summaryrefslogtreecommitdiff
path: root/meta-amd/recipes-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 16:57:07 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 17:06:20 +0300
commitc7d1cd9477b2f14e48524da420e1528f6036c8b6 (patch)
tree22c0f5f735b505b82610cc0f8190aae12a80347e /meta-amd/recipes-phosphor
parentef2307412f38a174f511852bedcbe9974e68674d (diff)
downloadopenbmc-c7d1cd9477b2f14e48524da420e1528f6036c8b6.tar.xz
meta-amd: subtree update:0ec4f9ff17..496d83825e
Supreeth Venkatesh (22): meta-amd: Add recipe for power control. meta-amd: Override watchdog recipe. meta-amd: Override fans and sel-logger recipes. meta-amd: Define OpenBMC AMD package group applications. meta-amd: Add Linux kernel recipe for EthanolX. meta-amd: EthanolX platform configuration meta-amd: Enable bmcweb and phosphor-webui meta-amd: Enable LED Group Management for Ethanolx meta-amd: Enable OOB BMC firmware update meta-amd: Enable SOL host console meta-amd: Modify device tree to enable thermal sensors for EthanolX meta-amd: Enable hwmon to monitor thermal sensors and fan meta-amd: Enable ipmi fru and sensor configuration meta-amd: Add ipmi config, host and fru .bbappend files meta-amd: Add entity-manager and ipmitool modules meta-amd:linux: Added I2c0 and I2c1 which cater to AMD's APML Interface meta-amd: Remove device tree patch meta-amd: Add device tree patch meta-amd: Add chassis control application meta-amd: Add phosphor host logger application meta-amd: Add fan tach sensor for fan 0 and fan 1 meta-amd: Remove bmcweb bbappend file Change-Id: I53d6f4be203eefce1475d588b55fdf785b2b2024 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-amd/recipes-phosphor')
-rw-r--r--meta-amd/recipes-phosphor/console/obmc-console/ethanolx/server.ttyS0.conf2
-rw-r--r--meta-amd/recipes-phosphor/console/obmc-console_%.bbappend15
-rw-r--r--meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend3
-rw-r--r--meta-amd/recipes-phosphor/logging/phosphor-hostlogger/ethanolx/ttyS0.conf7
-rw-r--r--meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend8
-rw-r--r--meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend3
6 files changed, 38 insertions, 0 deletions
diff --git a/meta-amd/recipes-phosphor/console/obmc-console/ethanolx/server.ttyS0.conf b/meta-amd/recipes-phosphor/console/obmc-console/ethanolx/server.ttyS0.conf
new file mode 100644
index 000000000..88d84d7ca
--- /dev/null
+++ b/meta-amd/recipes-phosphor/console/obmc-console/ethanolx/server.ttyS0.conf
@@ -0,0 +1,2 @@
+local-tty = ttyS0
+baud = 115200
diff --git a/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
new file mode 100644
index 000000000..7f9c460e2
--- /dev/null
+++ b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS0"
+
+SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI += "file://server.ttyS0.conf"
+
+do_install_append() {
+ # Remove upstream-provided configuration
+ rm -rf ${D}${sysconfdir}/${BPN}
+
+ # Install the server configuration
+ install -m 0755 -d ${D}${sysconfdir}/${BPN}
+ install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
+
+}
diff --git a/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
new file mode 100644
index 000000000..83567e906
--- /dev/null
+++ b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+EXTRA_OECONF_append = " --enable-configure-dbus=yes"
diff --git a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger/ethanolx/ttyS0.conf b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger/ethanolx/ttyS0.conf
new file mode 100644
index 000000000..c75186415
--- /dev/null
+++ b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger/ethanolx/ttyS0.conf
@@ -0,0 +1,7 @@
+SOCKET_ID=
+BUF_MAXSIZE=3000
+BUF_MAXTIME=0
+FLUSH_FULL=false
+HOST_STATE=/xyz/openbmc_project/state/host0
+OUT_DIR=/var/lib/obmc/hostlogs
+MAX_FILES=10
diff --git a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
new file mode 100644
index 000000000..9ae1d42c6
--- /dev/null
+++ b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+
+# Default service instance to install (single-host mode)
+DEFAULT_INSTANCE = "ttyS0"
+
+SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI += "file://ttyS0.conf"
+
diff --git a/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
new file mode 100644
index 000000000..4948cb4cb
--- /dev/null
+++ b/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -0,0 +1,3 @@
+# Enable threshold monitoring
+EXTRA_OECMAKE += "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON"
+EXTRA_OECMAKE += "-DREDFISH_LOG_MONITOR_PULSE_EVENTS=ON"