summaryrefslogtreecommitdiff
path: root/meta-amd
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2021-09-01 11:34:44 +0300
committerKonstantin Aladyshev <aladyshev22@gmail.com>2021-09-10 16:22:18 +0300
commit2de8c6037ff56bf950c6af048fccc9d07f952387 (patch)
treeb53ae09cfbe48ea3979fe9503029037636c58fad /meta-amd
parentac568e75cc8e194f52a7d7ed2e596f3b9d7e7418 (diff)
downloadopenbmc-2de8c6037ff56bf950c6af048fccc9d07f952387.tar.xz
meta-amd: fix compilation errors with latest Yocto
Make the following changes to fix compilation errors: - add honister to the LAYERSERIES_COMPAT variable, - increase CONF_VERSION to 2, - use new bitbake override syntax Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com> Change-Id: I971f0f0f7110e0350994ced151ca429444885056
Diffstat (limited to 'meta-amd')
-rw-r--r--meta-amd/conf/layer.conf2
-rw-r--r--meta-amd/meta-ethanolx/conf/layer.conf2
-rw-r--r--meta-amd/meta-ethanolx/conf/local.conf.sample8
-rw-r--r--meta-amd/meta-ethanolx/conf/machine/ethanolx.conf2
-rw-r--r--meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed_%.bbappend2
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend6
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/ethanolx-yaml-config.bb4
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend2
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend4
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend4
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/sensors/dbus-sensors_%.bbappend2
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend2
-rw-r--r--meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend2
-rw-r--r--meta-amd/recipes-amd/amd-fpga/amd-fpga.bb4
-rw-r--r--meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb24
-rw-r--r--meta-amd/recipes-phosphor/console/obmc-console_%.bbappend6
-rw-r--r--meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend4
-rw-r--r--meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend4
-rw-r--r--meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend2
19 files changed, 43 insertions, 43 deletions
diff --git a/meta-amd/conf/layer.conf b/meta-amd/conf/layer.conf
index 7fc59b9ac..db636c17a 100644
--- a/meta-amd/conf/layer.conf
+++ b/meta-amd/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "amd-layer"
BBFILE_PATTERN_amd-layer = "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_amd-layer = "hardknott"
+LAYERSERIES_COMPAT_amd-layer = "hardknott honister"
diff --git a/meta-amd/meta-ethanolx/conf/layer.conf b/meta-amd/meta-ethanolx/conf/layer.conf
index 0564fe424..37f32bcb3 100644
--- a/meta-amd/meta-ethanolx/conf/layer.conf
+++ b/meta-amd/meta-ethanolx/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "ethanolx-layer"
BBFILE_PATTERN_ethanolx-layer = "^${LAYERDIR}/"
BBFILE_PRIORITY_ethanolx-layer = "6"
-LAYERSERIES_COMPAT_ethanolx-layer = "hardknott"
+LAYERSERIES_COMPAT_ethanolx-layer = "hardknott honister"
diff --git a/meta-amd/meta-ethanolx/conf/local.conf.sample b/meta-amd/meta-ethanolx/conf/local.conf.sample
index 34a13a566..27e36f84d 100644
--- a/meta-amd/meta-ethanolx/conf/local.conf.sample
+++ b/meta-amd/meta-ethanolx/conf/local.conf.sample
@@ -115,7 +115,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# Supported values are i686 and x86_64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
+SANITY_TESTED_DISTROS:append ?= " RedHatEnterpriseWorkstation-6.*"
#
# Extra image configuration defaults
@@ -226,12 +226,12 @@ BB_DISKMON_DIRS = "\
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. This assumes there is a
# libsdl library available on your build system.
-PACKAGECONFIG_append_pn-qemu-native = " sdl"
-PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+PACKAGECONFIG:append:pn-qemu-native = " sdl"
+PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
#ASSUME_PROVIDED += "libsdl-native"
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
+CONF_VERSION = "2"
diff --git a/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf b/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
index 7fb6e7ec1..2ac82cade 100644
--- a/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
+++ b/meta-amd/meta-ethanolx/conf/machine/ethanolx.conf
@@ -2,7 +2,7 @@
KMACHINE = "aspeed"
KERNEL_DEVICETREE = "${KMACHINE}-bmc-amd-${MACHINE}.dtb"
-UBOOT_MACHINE_ethanolx = "ast_g5_phy_config"
+UBOOT_MACHINE:ethanolx = "ast_g5_phy_config"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed_%.bbappend
index 9f7f1b99d..ec2f52726 100644
--- a/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-aspeed:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-aspeed:"
SRC_URI += "file://ethanolx.cfg"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
index 5a287694d..f55bf2390 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-SRC_URI_append = " file://ethanolx-baseboard.json \
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
+SRC_URI:append = " file://ethanolx-baseboard.json \
file://ethanolx-chassis.json"
-do_install_append() {
+do_install:append() {
rm -f ${D}/usr/share/entity-manager/configurations/*.json
install -d ${D}/usr/share/entity-manager/configurations
install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}/usr/share/entity-manager/configurations
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/ethanolx-yaml-config.bb b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/ethanolx-yaml-config.bb
index efa208374..c7226ae1f 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/ethanolx-yaml-config.bb
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/ethanolx-yaml-config.bb
@@ -24,10 +24,10 @@ do_install() {
${D}${datadir}/${BPN}/ipmi-sensors.yaml
}
-FILES_${PN}-dev = " \
+FILES:${PN}-dev = " \
${datadir}/${BPN}/ipmi-extra-properties.yaml \
${datadir}/${BPN}/ipmi-fru-read.yaml \
${datadir}/${BPN}/ipmi-sensors.yaml \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 66444b9ce..557d268f5 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_ethanolx := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:ethanolx := "${THISDIR}/${PN}:"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 706e192d2..d92ca4c05 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -1,6 +1,6 @@
-DEPENDS_append_ethanolx = " ethanolx-yaml-config"
+DEPENDS:append:ethanolx = " ethanolx-yaml-config"
-EXTRA_OECONF_ethanolx = " \
+EXTRA_OECONF:ethanolx = " \
YAML_GEN=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-fru-read.yaml \
PROP_YAML=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-extra-properties.yaml \
"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 8e60f458e..7d52980c4 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,6 +1,6 @@
-DEPENDS_append_ethanolx = " ethanolx-yaml-config"
+DEPENDS:append:ethanolx = " ethanolx-yaml-config"
-EXTRA_OECONF_ethanolx = " \
+EXTRA_OECONF:ethanolx = " \
SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-sensors.yaml \
FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-fru-read.yaml \
"
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/sensors/dbus-sensors_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/sensors/dbus-sensors_%.bbappend
index 856cf1004..5d88d073e 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/sensors/dbus-sensors_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/sensors/dbus-sensors_%.bbappend
@@ -1,4 +1,4 @@
-PACKAGECONFIG_ethanolx = "\
+PACKAGECONFIG:ethanolx = "\
hwmontempsensor \
fansensor \
psusensor \
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
index ae55f69d9..f1c5acabc 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append_ethanolx = " boot_type"
+PACKAGECONFIG:append:ethanolx = " boot_type"
diff --git a/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend
index 1cf276dce..662090ea0 100644
--- a/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-Amd-power-control-modifications-for-EthanolX.patch"
SRCREV = "01a77864f49088bac80474587a123d1f152f2b26"
diff --git a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
index 32efddea2..79c80b012 100644
--- a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
+++ b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
SUMMARY = "AMD Ethanolx FPGA Register Dump Utility"
DESCRIPTION = "AMD Ethanolx FPGA Register Dump Utility"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5e24678b8d0883d9dfa9e9473069ddd2"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
SRCREV = "${AUTOREV}"
SRC_URI = "file://fpgardu.sh"
SRC_URI += "file://LICENSE"
diff --git a/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb b/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
index 33e66f568..06938055c 100644
--- a/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
+++ b/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
@@ -16,27 +16,27 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "AMD Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "AMD Chassis"
+RDEPENDS:${PN}-chassis = " \
x86-power-control \
obmc-host-failure-reboots \
"
-SUMMARY_${PN}-fans = "AMD Fans"
-RDEPENDS_${PN}-fans = ""
+SUMMARY:${PN}-fans = "AMD Fans"
+RDEPENDS:${PN}-fans = ""
-SUMMARY_${PN}-flash = "AMD Flash"
-RDEPENDS_${PN}-flash = " \
+SUMMARY:${PN}-flash = "AMD Flash"
+RDEPENDS:${PN}-flash = " \
phosphor-software-manager \
"
-SUMMARY_${PN}-system = "AMD System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "AMD System"
+RDEPENDS:${PN}-system = " \
amd-fpga \
bmcweb \
dbus-sensors \
diff --git a/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
index 7f9c460e2..a53372431 100644
--- a/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
OBMC_CONSOLE_HOST_TTY = "ttyS0"
-SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI:remove = "file://${BPN}.conf"
SRC_URI += "file://server.ttyS0.conf"
-do_install_append() {
+do_install:append() {
# Remove upstream-provided configuration
rm -rf ${D}${sysconfdir}/${BPN}
diff --git a/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 83567e906..4cdfe5a9e 100644
--- a/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-EXTRA_OECONF_append = " --enable-configure-dbus=yes"
+EXTRA_OECONF:append = " --enable-configure-dbus=yes"
diff --git a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
index 9ae1d42c6..1f2e6c038 100644
--- a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
+++ b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
# Default service instance to install (single-host mode)
DEFAULT_INSTANCE = "ttyS0"
-SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI:remove = "file://${BPN}.conf"
SRC_URI += "file://ttyS0.conf"
diff --git a/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend b/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
index ac98c7ce7..ca35bcb6a 100644
--- a/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
+++ b/meta-amd/recipes-phosphor/sel-logger/phosphor-sel-logger_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append = " log-threshold log-pulse"
+PACKAGECONFIG:append = " log-threshold log-pulse"